summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-06-22 17:21:44 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-06-22 17:24:01 -0500
commit6e46f83c4ed842113b7d9feb2806c803dbecd637 (patch)
treed379943fd82feeb1184c747c257b0faf902ebfe3 /net-misc/rclone
parentnet-vpn/wireguard-tools: check for NETFILTER_XT_MATCH_ADDRTYPE (diff)
downloadgentoo-6e46f83c4ed842113b7d9feb2806c803dbecd637.tar.gz
gentoo-6e46f83c4ed842113b7d9feb2806c803dbecd637.tar.bz2
gentoo-6e46f83c4ed842113b7d9feb2806c803dbecd637.zip
net-fs/minio: version bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-misc/rclone')
-rw-r--r--net-misc/rclone/rclone-1.52.1.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/net-misc/rclone/rclone-1.52.1.ebuild b/net-misc/rclone/rclone-1.52.1.ebuild
index 380576cdebc5..9617d4c91b19 100644
--- a/net-misc/rclone/rclone-1.52.1.ebuild
+++ b/net-misc/rclone/rclone-1.52.1.ebuild
@@ -2,17 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
-inherit golang-build bash-completion-r1
-EGO_PN="github.com/rclone/${PN}"
+inherit bash-completion-r1 go-module
if [[ ${PV} == *9999* ]]; then
- inherit golang-vcs
+ inherit git-r3
else
KEYWORDS="amd64 ~arm ~arm64 x86"
- EGIT_COMMIT="v${PV}"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/rclone/rclone/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
DESCRIPTION="A program to sync files to and from various cloud storage providers"
@@ -22,13 +18,14 @@ LICENSE="MIT"
SLOT="0"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+src_compile() {
+ go build -mod=vendor . || die "compile failed"
+}
src_install() {
dobin ${PN}
- doman src/${EGO_PN}/${PN}.1
- dodoc src/${EGO_PN}/README.md
+ doman ${PN}.1
+ dodoc README.md
./rclone genautocomplete bash ${PN}.bash || die
newbashcomp ${PN}.bash ${PN}