summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-09-14 11:49:46 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2015-09-14 11:50:56 +0200
commite2580ebfc62c357aa1d82cedd08607bc628eb638 (patch)
tree2605f88c1dc9fd765850b387c86d162ed2110fb0 /net-misc/rdesktop
parentmail-client/claws-mail: Removed old. (diff)
downloadgentoo-e2580ebfc62c357aa1d82cedd08607bc628eb638.tar.gz
gentoo-e2580ebfc62c357aa1d82cedd08607bc628eb638.tar.bz2
gentoo-e2580ebfc62c357aa1d82cedd08607bc628eb638.zip
net-misc/rdesktop: fix libXrandr automagic dep, bug #542952
Drop unneeded patch Fix openssl slot Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-misc/rdesktop')
-rw-r--r--net-misc/rdesktop/files/rdesktop-1.8.3-xrandr_configure.patch17
-rw-r--r--net-misc/rdesktop/metadata.xml1
-rw-r--r--net-misc/rdesktop/rdesktop-1.8.3-r1.ebuild75
3 files changed, 93 insertions, 0 deletions
diff --git a/net-misc/rdesktop/files/rdesktop-1.8.3-xrandr_configure.patch b/net-misc/rdesktop/files/rdesktop-1.8.3-xrandr_configure.patch
new file mode 100644
index 000000000000..f57a86b4315b
--- /dev/null
+++ b/net-misc/rdesktop/files/rdesktop-1.8.3-xrandr_configure.patch
@@ -0,0 +1,17 @@
+--- configure.ac.orig 2015-09-14 11:27:54.974472081 +0200
++++ configure.ac 2015-09-14 11:34:37.729155044 +0200
+@@ -151,9 +151,12 @@
+ AC_SUBST(CREDSSPOBJ)
+
+ # xrandr
+-if test -n "$PKG_CONFIG"; then
+- PKG_CHECK_MODULES(XRANDR, xrandr, [HAVE_XRANDR=1], [HAVE_XRANDR=0])
++AC_ARG_WITH([xrandr], AS_HELP_STRING([--without-xrandr], [Build without Xrandr library (default: true)]))
++AS_IF([test "x$with_xrandr" != "xno"], [
++ if test -n "$PKG_CONFIG"; then
++ PKG_CHECK_MODULES(XRANDR, xrandr, [HAVE_XRANDR=1], [HAVE_XRANDR=0])
+ fi
++])
+ if test x"$HAVE_XRANDR" = "x1"; then
+ CFLAGS="$CFLAGS $XRANDR_CFLAGS"
+ LIBS="$LIBS $XRANDR_LIBS"
diff --git a/net-misc/rdesktop/metadata.xml b/net-misc/rdesktop/metadata.xml
index cbeac8797d75..5c63e86dc8ef 100644
--- a/net-misc/rdesktop/metadata.xml
+++ b/net-misc/rdesktop/metadata.xml
@@ -11,6 +11,7 @@ An open source client for Windows NT Terminal Server and Windows 2000/2003 Termi
<use>
<flag name="kerberos">Enable CredSPP support + Kerberos authentication with <pkg>net-libs/libgssglue</pkg></flag>
<flag name="pcsc-lite">Enable smartcard support with <pkg>sys-apps/pcsc-lite</pkg> driver</flag>
+ <flag name='xrandr'>Enable XRandR window extension support</flag>
</use>
<upstream>
<remote-id type="sourceforge">rdesktop</remote-id>
diff --git a/net-misc/rdesktop/rdesktop-1.8.3-r1.ebuild b/net-misc/rdesktop/rdesktop-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..397dc2049632
--- /dev/null
+++ b/net-misc/rdesktop/rdesktop-1.8.3-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A Remote Desktop Protocol Client"
+HOMEPAGE="http://rdesktop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="alsa ao debug ipv6 kerberos libsamplerate oss pcsc-lite xrandr"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+RDEPEND=">=dev-libs/openssl-0.9.6b:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ alsa? ( media-libs/alsa-lib )
+ ao? ( >=media-libs/libao-0.8.6 )
+ kerberos? ( net-libs/libgssglue )
+ libsamplerate? ( media-libs/libsamplerate )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-libs/libXt"
+
+src_prepare() {
+ # Prevent automatic stripping
+ local strip="$(echo '$(STRIP) $(DESTDIR)$(bindir)/rdesktop')"
+ sed -i -e "s:${strip}::" Makefile.in \
+ || die "sed failed in Makefile.in"
+
+ # Automagic dependencies
+ epatch "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
+ epatch "${FILESDIR}"/${P}-xrandr_configure.patch
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ if use ao; then
+ sound_conf=$(use_with ao sound libao)
+ else if use alsa; then
+ sound_conf=$(use_with alsa sound alsa)
+ else
+ sound_conf=$(use_with oss sound oss)
+ fi
+ fi
+
+ econf \
+ --with-openssl="${EPREFIX}"/usr \
+ $(use_with debug) \
+ $(use_with ipv6) \
+ $(use_with libsamplerate) \
+ $(use_with xrandr) \
+ $(use_enable kerberos credssp) \
+ $(use_enable pcsc-lite smartcard) \
+ ${sound_conf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/HACKING doc/TODO doc/keymapping.txt
+}