summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-04-15 20:30:30 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-04-15 20:47:46 +0200
commit78f2dc7cabbf8c18570d9bae4818956aa2ae8c38 (patch)
treec209abbc4cb189ac87e2142195e61b667767d104 /net-misc/redir/redir-2.2.1-r1.ebuild
parentsci-libs/ogdi: stable 3.2.0 for ppc64, bug #649484 (diff)
downloadgentoo-78f2dc7cabbf8c18570d9bae4818956aa2ae8c38.tar.gz
gentoo-78f2dc7cabbf8c18570d9bae4818956aa2ae8c38.tar.bz2
gentoo-78f2dc7cabbf8c18570d9bae4818956aa2ae8c38.zip
net-misc/redir: EAPI 6 bump.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-misc/redir/redir-2.2.1-r1.ebuild')
-rw-r--r--net-misc/redir/redir-2.2.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/redir/redir-2.2.1-r1.ebuild b/net-misc/redir/redir-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..104aafdcf4cb
--- /dev/null
+++ b/net-misc/redir/redir-2.2.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Redir is a port redirector"
+HOMEPAGE="http://sammy.net/~sammy/hacks/"
+SRC_URI="http://sammy.net/~sammy/hacks/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~sparc ~x86"
+
+PATCHES=( "${FILESDIR}/${P}-include.patch" )
+DOCS=( CHANGES README transproxy.txt )
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ newman "${PN}.man" "${PN}.1"
+}