summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-10-09 22:08:48 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-10-10 08:39:58 +0200
commitde6a0126d8a2534653839add01c29424e5a8311a (patch)
tree4cccf9b902496f830ecc3aa71e6f54e2744dea0c /net-misc/s3cmd/s3cmd-2.0.2.ebuild
parentdev-python/pep257: new package. (diff)
downloadgentoo-de6a0126d8a2534653839add01c29424e5a8311a.tar.gz
gentoo-de6a0126d8a2534653839add01c29424e5a8311a.tar.bz2
gentoo-de6a0126d8a2534653839add01c29424e5a8311a.zip
net-misc/s3cmd: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'net-misc/s3cmd/s3cmd-2.0.2.ebuild')
-rw-r--r--net-misc/s3cmd/s3cmd-2.0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-misc/s3cmd/s3cmd-2.0.2.ebuild b/net-misc/s3cmd/s3cmd-2.0.2.ebuild
new file mode 100644
index 000000000000..c8ebf64df130
--- /dev/null
+++ b/net-misc/s3cmd/s3cmd-2.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5,6}} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Command line client for Amazon S3"
+HOMEPAGE="https://s3tools.org/s3cmd"
+SRC_URI="mirror://sourceforge/s3tools/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ia64 ~x86 ~x64-macos"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]"
+
+S="$WORKDIR/${P/_/-}"