summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/s3cmd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/s3cmd')
-rw-r--r--net-misc/s3cmd/Manifest2
-rw-r--r--net-misc/s3cmd/metadata.xml20
-rw-r--r--net-misc/s3cmd/s3cmd-1.0.1.ebuild33
-rw-r--r--net-misc/s3cmd/s3cmd-1.5.2-r1.ebuild31
4 files changed, 86 insertions, 0 deletions
diff --git a/net-misc/s3cmd/Manifest b/net-misc/s3cmd/Manifest
new file mode 100644
index 000000000000..6350b8a97a42
--- /dev/null
+++ b/net-misc/s3cmd/Manifest
@@ -0,0 +1,2 @@
+DIST s3cmd-1.0.1.tar.gz 57594 SHA256 d76826ea9c5a4789044424f1a50abe83523ba5d12a9185c7a6b7f4c86984bdce SHA512 daddb6c49a22cb2c9196d69116abddc639ab117b8a21413068e33e76f67dff5a21d6dca9a9d385113651fa996ace2359684709b2a3be33f4404ad79ed3d44814 WHIRLPOOL d151d9581359fd8dcc23550bc45fc972ab349153e7488d8d9e28c18857e5d550e834ae16274029797a4d2a096aa988e780ad82756f4f1b2a936002667ac96186
+DIST s3cmd-1.5.2.tar.gz 94760 SHA256 ff8a6764e8bdd7ed48a93e51b08222bea33469d248a90b8d25315b023717b42d SHA512 6493d1c2739c79611ab986882842c4c161a466fdd91a6d48b68ddfa14d7743a9b5dde77902efae336bd632827497ab83962d5835c89135e8f9109d45e14b1e9a WHIRLPOOL ec5fec5e803a87b75689f4bba3f5913c8854d6035b34f5267e4da80a47c86925fdcd053eab24f4bf35b8b1ee2bccd41f7882b6c9fb3b6fdb0257c5ca492dc805
diff --git a/net-misc/s3cmd/metadata.xml b/net-misc/s3cmd/metadata.xml
new file mode 100644
index 000000000000..06966dc83fc3
--- /dev/null
+++ b/net-misc/s3cmd/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>igor@itesten.com</email>
+ <name>Igor Testen</name>
+ <description>Proxy maintainer, assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <longdescription>
+ Command line client for Amazon S3.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">s3tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/s3cmd/s3cmd-1.0.1.ebuild b/net-misc/s3cmd/s3cmd-1.0.1.ebuild
new file mode 100644
index 000000000000..88128f58129a
--- /dev/null
+++ b/net-misc/s3cmd/s3cmd-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="xml"
+
+inherit distutils
+
+KEYWORDS="amd64 x86"
+DESCRIPTION="Command line client for Amazon S3"
+HOMEPAGE="http://s3tools.org/s3cmd"
+SRC_URI="mirror://sourceforge/s3tools/${P}.tar.gz"
+LICENSE="GPL-2"
+
+IUSE=""
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+PYTHON_MODNAME="S3"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ S3CMD_INSTPATH_DOC=/usr/share/doc/${PF} distutils_src_install
+ rm -rf "${D}"/usr/share/doc/${PF}/${PN} || die 'rm failed'
+}
diff --git a/net-misc/s3cmd/s3cmd-1.5.2-r1.ebuild b/net-misc/s3cmd/s3cmd-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..562e2fa8de2a
--- /dev/null
+++ b/net-misc/s3cmd/s3cmd-1.5.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Command line client for Amazon S3"
+HOMEPAGE="http://s3tools.org/s3cmd"
+SRC_URI="mirror://sourceforge/s3tools/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]"
+
+S="$WORKDIR/${P/_/-}"
+
+python_install_all() {
+ # setup/py doesn't intereact well with the eclass
+ distutils-r1_python_install_all
+# rm -rf "${D}"usr/share/doc/packages || die
+}