summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2021-08-25 15:58:35 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2021-08-25 15:58:49 -0700
commit6e5bdd2815b07253db94bda78440cdb3b19338cf (patch)
tree38fadef0e618f6f3e49d04a57551a47172a7270b /net-misc/s4cmd
parentsys-apps/inxi: Remove old (diff)
downloadgentoo-6e5bdd2815b07253db94bda78440cdb3b19338cf.tar.gz
gentoo-6e5bdd2815b07253db94bda78440cdb3b19338cf.tar.bz2
gentoo-6e5bdd2815b07253db94bda78440cdb3b19338cf.zip
net-misc/s4cmd: new package
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-misc/s4cmd')
-rw-r--r--net-misc/s4cmd/Manifest1
-rw-r--r--net-misc/s4cmd/metadata.xml7
-rw-r--r--net-misc/s4cmd/s4cmd-2.1.0.ebuild29
3 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/s4cmd/Manifest b/net-misc/s4cmd/Manifest
new file mode 100644
index 000000000000..b9594713d437
--- /dev/null
+++ b/net-misc/s4cmd/Manifest
@@ -0,0 +1 @@
+DIST s4cmd-2.1.0.tar.gz 39312 BLAKE2B 9d2d533273543153f2bad69362933315f65c5e70bd45c102e42b1b733989815239ae4d027ac08d658f03263bd9dd75f1f6db802b5f38ed3256da5e7c9f48558c SHA512 05e930e2789ce8ab280dcdb2f08e4162930d946d2ed2e4f1c754c8b875375774779b73729151bd23d9bf3736bc48f7626fe53df66aff71dd11b32e90e9355470
diff --git a/net-misc/s4cmd/metadata.xml b/net-misc/s4cmd/metadata.xml
new file mode 100644
index 000000000000..79d462e85571
--- /dev/null
+++ b/net-misc/s4cmd/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/s4cmd/s4cmd-2.1.0.ebuild b/net-misc/s4cmd/s4cmd-2.1.0.ebuild
new file mode 100644
index 000000000000..c15fbeeee59f
--- /dev/null
+++ b/net-misc/s4cmd/s4cmd-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 python3_10 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1 bash-completion-r1
+
+DESCRIPTION="Super S3 command line tool"
+HOMEPAGE="https://github.com/bloomreach/s4cmd"
+SRC_URI="https://github.com/bloomreach/s4cmd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_install() {
+ distutils-r1_src_install
+ dobashcomp data/bash-completion/s4cmd
+ rm -f "${D}"/usr/bin/s4cmd.py
+}