summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/slimrat/slimrat-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/slimrat/slimrat-9999.ebuild')
-rw-r--r--net-misc/slimrat/slimrat-9999.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/slimrat/slimrat-9999.ebuild b/net-misc/slimrat/slimrat-9999.ebuild
new file mode 100644
index 000000000000..494f78cffd32
--- /dev/null
+++ b/net-misc/slimrat/slimrat-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils subversion
+
+DESCRIPTION="Linux Rapidshare downloader"
+HOMEPAGE="http://code.google.com/p/slimrat/"
+SRC_URI=""
+ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="X"
+
+DEPEND="
+ >=dev-lang/perl-5.10.1[ithreads]
+ dev-perl/JSON
+ >=dev-perl/WWW-Mechanize-1.52
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ X? (
+ dev-perl/gtk2-gladexml
+ dev-perl/Spiffy
+ x11-misc/xclip
+ )
+"
+# aview: displaying captcha
+RDEPEND="${DEPEND}
+ media-gfx/aview
+ X? ( x11-terms/xterm )
+"
+
+src_prepare() {
+ esvn_clean
+}
+
+src_install() {
+ # install binaries
+
+ exeinto "/usr/share/${PN}"
+
+ doexe "src/${PN}"
+ dosym "/usr/share/${PN}/${PN}" "${ROOT}usr/bin/${PN}"
+
+ if use X; then
+ doexe "src/${PN}-gui"
+ dosym "/usr/share/${PN}/${PN}-gui" "/usr/bin/${PN}-gui"
+ fi
+
+ # install data
+ insinto /etc
+ newins "${S}/slimrat.conf" slimrat.conf
+
+ insinto "/usr/share/${PN}"
+ doins -r "src/"*.pm "src/plugins/" "src/${PN}.glade"
+}