summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-05-19 17:38:42 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-06-04 06:44:38 +0200
commitb650d7022dc2ae1767c9f1b6bc0932f2752f71b4 (patch)
tree76ab3aad5eddcb7b30657f6fb3f87b4850d1387b /net-misc/smbc/smbc-1.2.2-r3.ebuild
parentnet-misc/smbc: fix LICENSE (diff)
downloadgentoo-b650d7022dc2ae1767c9f1b6bc0932f2752f71b4.tar.gz
gentoo-b650d7022dc2ae1767c9f1b6bc0932f2752f71b4.tar.bz2
gentoo-b650d7022dc2ae1767c9f1b6bc0932f2752f71b4.zip
net-misc/smbc: EAPI=7 bump
Closes: https://bugs.gentoo.org/686328 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Diffstat (limited to 'net-misc/smbc/smbc-1.2.2-r3.ebuild')
-rw-r--r--net-misc/smbc/smbc-1.2.2-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/smbc/smbc-1.2.2-r3.ebuild b/net-misc/smbc/smbc-1.2.2-r3.ebuild
new file mode 100644
index 000000000000..87ebd6eea0a6
--- /dev/null
+++ b/net-misc/smbc/smbc-1.2.2-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Text mode (ncurses) SMB network commander. Features: resume and UTF-8"
+HOMEPAGE="https://sourceforge.net/projects/smbc/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="nls debug"
+
+DEPEND="dev-libs/popt
+ net-fs/samba
+ sys-libs/ncurses
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eapply "${FILESDIR}"/${P}-cflags.patch
+ eapply "${FILESDIR}"/${P}-size_t.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with debug)
+}
+
+src_install() {
+ default
+ mkdir -p "${D}/usr/share/doc"
+ mv -v "${D}/usr/share/"{${PN},doc/${PF}} || die
+}