summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-18 10:11:26 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-18 10:23:24 +0100
commit2bc489a402a15d403c835b6e9619fa68cdf1d1e2 (patch)
tree4356ff23af7456402ae2e66b5fff80d216a8c431 /net-misc/spiped
parentapp-shells/hstr: clean up old. (diff)
downloadgentoo-2bc489a402a15d403c835b6e9619fa68cdf1d1e2.tar.gz
gentoo-2bc489a402a15d403c835b6e9619fa68cdf1d1e2.tar.bz2
gentoo-2bc489a402a15d403c835b6e9619fa68cdf1d1e2.zip
net-misc/spiped: add libressl support.
Package-Manager: portage-2.3.3
Diffstat (limited to 'net-misc/spiped')
-rw-r--r--net-misc/spiped/spiped-1.5.0-r3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/spiped/spiped-1.5.0-r3.ebuild b/net-misc/spiped/spiped-1.5.0-r3.ebuild
new file mode 100644
index 000000000000..194fc4c08189
--- /dev/null
+++ b/net-misc/spiped/spiped-1.5.0-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="secure pipe daemon"
+HOMEPAGE="http://www.tarsnap.com/spiped.html"
+SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+MY_PN="${PN/d/}"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+
+# Blocker added due to #548126
+RDEPEND="
+ ${DEPEND}
+ !net-mail/qlogtools"
+
+src_install() {
+ dobin "${MY_PN}/${MY_PN}"
+ dosbin "${PN}/${PN}"
+
+ doman "${MY_PN}/${MY_PN}.1" "${PN}/${PN}.1"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ dodir "etc/${PN}"
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure spiped via its"
+ elog "configuration file located in /etc/conf.d/."
+ elog
+ elog "Please have a look at this file prior to starting up spiped!"
+ elog
+}