summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-08-21 17:18:55 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-08-21 17:31:53 +0000
commitb1aaecf3778c2c42fc8cb321004c157857a89c81 (patch)
tree39a56fe9c5ebaa7e22b2b490fd5b95735f6ef5ef /net-misc/spiped
parentkde-base/kdelibs: raise cmake dependency. (diff)
downloadgentoo-b1aaecf3778c2c42fc8cb321004c157857a89c81.tar.gz
gentoo-b1aaecf3778c2c42fc8cb321004c157857a89c81.tar.bz2
gentoo-b1aaecf3778c2c42fc8cb321004c157857a89c81.zip
net-misc/spiped: stick a blocker on net-mail/qlogtools due to file collisions. Fixes bug 548126.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-misc/spiped')
-rw-r--r--net-misc/spiped/spiped-1.5.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/spiped/spiped-1.5.0-r1.ebuild b/net-misc/spiped/spiped-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..caf32dac1ce1
--- /dev/null
+++ b/net-misc/spiped/spiped-1.5.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="secure pipe daemon"
+HOMEPAGE="http://www.tarsnap.com/spiped.html"
+SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+MY_PN="${PN/d/}"
+
+DEPEND="dev-libs/openssl:*"
+
+# Blocker added due to #548126
+RDEPEND="${DEPEND}
+ !net-mail/qlogtools"
+
+src_install() {
+ dobin ${MY_PN}/${MY_PN}
+ dosbin ${PN}/${PN}
+
+ doman ${MY_PN}/"${MY_PN}.1" ${PN}/"${PN}.1"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ dodir etc/${PN}
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure spiped via its"
+ elog "configuration file located in /etc/conf.d/."
+ elog
+ elog "Please have a look at this file prior to starting up spiped!"
+ elog
+}