summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-04-01 13:55:01 +0200
committerUlrich Müller <ulm@gentoo.org>2018-04-01 13:59:16 +0200
commita01f661ac006818d8ee6dd4283df6a850ee1f3a4 (patch)
tree7b6f02eccc45c78521819265ecba4120f695ca13 /net-misc/ssvnc/ssvnc-1.0.29-r2.ebuild
parentmedia-gfx/curaengine: Add missing DEPs, remove broken test (diff)
downloadgentoo-a01f661ac006818d8ee6dd4283df6a850ee1f3a4.tar.gz
gentoo-a01f661ac006818d8ee6dd4283df6a850ee1f3a4.tar.bz2
gentoo-a01f661ac006818d8ee6dd4283df6a850ee1f3a4.zip
net-misc/ssvnc: Drop unnecessary X libraries.
Straight to stable, because only dependencies are affected, but installed files do not change. Closes: https://bugs.gentoo.org/649130 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'net-misc/ssvnc/ssvnc-1.0.29-r2.ebuild')
-rw-r--r--net-misc/ssvnc/ssvnc-1.0.29-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/ssvnc/ssvnc-1.0.29-r2.ebuild b/net-misc/ssvnc/ssvnc-1.0.29-r2.ebuild
new file mode 100644
index 000000000000..91bb7ba57993
--- /dev/null
+++ b/net-misc/ssvnc/ssvnc-1.0.29-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="VNC viewer that adds encryption security to VNC connections"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/ssvnc.html"
+SRC_URI="mirror://sourceforge/ssvnc/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="java"
+
+RDEPEND="sys-libs/zlib
+ virtual/jpeg:0
+ dev-libs/openssl:0=
+ dev-lang/tk:0
+ net-misc/stunnel
+ java? ( virtual/jre:* )
+ x11-terms/xterm
+ x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ java? ( virtual/jdk )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.29-build.patch )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^LIB/s:lib/:$(get_libdir)/:" \
+ -e "$(use java || echo '/^JSRC/s:=.*:=:')" \
+ Makefile || die
+ sed -i \
+ -e '/^CC/s:=.*:+= $(CFLAGS) $(CPPFLAGS) $(LDFLAGS):' \
+ vncstorepw/Makefile || die
+
+ cp "${FILESDIR}"/Makefile.libvncauth vnc_unixsrc/libvncauth/Makefile || die
+ cd "${S}"/vnc_unixsrc/vncviewer || die
+ sed -n '/^SRCS/,/^$/p' Imakefile > Makefile.in || die
+ cp "${FILESDIR}"/Makefile.vncviewer Makefile || die
+}
+
+src_compile() {
+ tc-export AR CC CXX RANLIB
+ emake all
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README
+}