summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2016-11-25 13:49:45 +0200
committerDavid Seifert <soap@gentoo.org>2016-11-26 13:04:36 +0100
commitb40df3fe09310190ab4075768c50f0293b4aa8b2 (patch)
tree1bc2fe3517aaf2f5a0f27c4aee05b51ac4fa8749 /net-misc/streamlink/streamlink-0.1.0.ebuild
parentsys-libs/slang: Bump to version 2.3.1a (diff)
downloadgentoo-b40df3fe09310190ab4075768c50f0293b4aa8b2.tar.gz
gentoo-b40df3fe09310190ab4075768c50f0293b4aa8b2.tar.bz2
gentoo-b40df3fe09310190ab4075768c50f0293b4aa8b2.zip
net-misc/streamlink: new package
Closes: https://github.com/gentoo/gentoo/pull/2912
Diffstat (limited to 'net-misc/streamlink/streamlink-0.1.0.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-0.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/streamlink/streamlink-0.1.0.ebuild b/net-misc/streamlink/streamlink-0.1.0.ebuild
new file mode 100644
index 000000000000..b9d43b9776ca
--- /dev/null
+++ b/net-misc/streamlink/streamlink-0.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ media-video/rtmpdump"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}