summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2017-08-20 19:31:42 +0300
committerMichał Górny <mgorny@gentoo.org>2017-09-02 20:45:00 +0200
commitb68d1785245c7c39e640e96cdc9de99fcfd014f2 (patch)
tree520bb91e4800148fc953867ee7a833a2fafdc646 /net-misc/streamlink
parentdev-libs/expat: arm64 stable, bug #622046 (diff)
downloadgentoo-b68d1785245c7c39e640e96cdc9de99fcfd014f2.tar.gz
gentoo-b68d1785245c7c39e640e96cdc9de99fcfd014f2.tar.bz2
gentoo-b68d1785245c7c39e640e96cdc9de99fcfd014f2.zip
net-misc/streamlink: version bump to 0.7.0
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-0.7.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 73d414a6dd7a..92256e3dacac 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,3 +1,4 @@
DIST streamlink-0.1.0.tar.gz 960622 SHA256 0a792cfe35c36f13b851bb79dc92e8a9515334c49221297258c9998f191ccecd SHA512 78b5bd9d35c2fc9c1d9fe3954b439e56cfee48f2b73a95a2c08a53c3a66143938ba162f2d2ba29c8af989565c920756cab605ae772d73828a3dd5a41fc6d30c2 WHIRLPOOL 5ba5dc69aecb06d8b1ba5372a327033b06d88bd38040278df0cac06c84663f7dcef29ae0921c4f36959a53eac7621d8df184bf9ea9bf5cbf6e5b2b2d7b4c8f23
DIST streamlink-0.4.0.tar.gz 30674625 SHA256 bb24ac2debc9efe5a0485db639621f45a854f686eee708a6bc8a3dc5f3807592 SHA512 58a4110b1e6b20f0b05842ee8450a93d646d523a284cf60ad878b460b8e80081d78658f5abb67744609cfdd0a88ebbf97faf6453b2b53709f259e4f9cc093eed WHIRLPOOL 21b47ad0bc96318218a83a9ee9bef29116c09f2384ef144f6910d2a08e6b3225f615576fa7a87a255be64b29ae24dad213a3b9f5e9a7b47d8497758c8ddfd222
DIST streamlink-0.6.0.tar.gz 30696706 SHA256 ec4e8f1c6b6bd2fa1211f996d1a43439bbb2e16c996ba264b5f3add520c204a5 SHA512 b9f75bfd2cab577688ed84a6c690f776b2e3af38fa60edb7f2fd73f2c25246c81098652180c3adae61eec8798a7805988cad01c366989a961efdb1e12578af49 WHIRLPOOL a179476180333086e63ad7282cbade6408fa55670d84db0ec926f41154bb8e1990102a42467a12bb8893ef452097b57f3690eccfb70f881ac8802d7d2147d4d0
+DIST streamlink-0.7.0.tar.gz 30709251 SHA256 f43bc00694b79c0a572089996ec885afe52b63d6f177e89cddefe5cf4a0d5387 SHA512 6e908229295c4d129d2bb9bfc26c76b20d45c2c9dc8193528a259c572cddd4ea620f9f903fb639ddad206bcad05a416ccc50328d01489a7684ec724a8cf1c3c1 WHIRLPOOL 333d2729254f5d6ce09a2881cb2f55cdad72dd5fb127861225df236876d3664025c615817a12d39242a0eecb38c413b939a5d705ccab55152c1ed0650638387e
diff --git a/net-misc/streamlink/streamlink-0.7.0.ebuild b/net-misc/streamlink/streamlink-0.7.0.ebuild
new file mode 100644
index 000000000000..65c5b4adf486
--- /dev/null
+++ b/net-misc/streamlink/streamlink-0.7.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/backports-shutil_which[$(python_gen_usedep 'python2*')]
+ dev-python/backports-shutil_get_terminal_size[$(python_gen_usedep 'python2*')]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ media-video/rtmpdump
+ virtual/ffmpeg"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[$(python_gen_usedep 'python2*')]
+ ${RDEPEND} )"
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use doc; then
+ local HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ fi
+ distutils-r1_python_install_all
+}