summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2016-08-04 14:49:22 +0100
committerTony Vroon <chainsaw@gentoo.org>2016-08-04 14:49:57 +0100
commitefa033a77238e3967d5078eb0fbc96a7626db295 (patch)
tree798cb312b81de260f53118a539297cb0b28190e1 /net-misc/stuntman/stuntman-1.2.9.ebuild
parentwww-client/firefox-48.0: fix dependencies (diff)
downloadgentoo-efa033a77238e3967d5078eb0fbc96a7626db295.tar.gz
gentoo-efa033a77238e3967d5078eb0fbc96a7626db295.tar.bz2
gentoo-efa033a77238e3967d5078eb0fbc96a7626db295.zip
net-misc/stuntman: Version bump to 1.2.9; remove 1.2.6 ebuilds.
Diffstat (limited to 'net-misc/stuntman/stuntman-1.2.9.ebuild')
-rw-r--r--net-misc/stuntman/stuntman-1.2.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/stuntman/stuntman-1.2.9.ebuild b/net-misc/stuntman/stuntman-1.2.9.ebuild
new file mode 100644
index 000000000000..7bb599de234f
--- /dev/null
+++ b/net-misc/stuntman/stuntman-1.2.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="STUNTMAN is an open source implementation of the STUN protocol"
+HOMEPAGE="http://www.stunprotocol.org"
+SRC_URI="http://www.stunprotocol.org/stunserver-${PV}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/boost
+ dev-libs/openssl:0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/stunserver"
+
+src_compile() {
+ emake T=""
+}
+
+src_install() {
+ dobin stunclient
+ dosbin stunserver
+ dodoc HISTORY README
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+src_test() {
+ ./stuntestcode
+}