summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/stuntman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/stuntman')
-rw-r--r--net-misc/stuntman/Manifest2
-rw-r--r--net-misc/stuntman/files/initd.v121
-rw-r--r--net-misc/stuntman/files/stuntman.confd7
-rw-r--r--net-misc/stuntman/files/stuntman.initd13
-rw-r--r--net-misc/stuntman/metadata.xml8
-rw-r--r--net-misc/stuntman/stuntman-1.2.6-r1.ebuild36
-rw-r--r--net-misc/stuntman/stuntman-1.2.6.ebuild38
-rw-r--r--net-misc/stuntman/stuntman-1.2.7.ebuild36
8 files changed, 161 insertions, 0 deletions
diff --git a/net-misc/stuntman/Manifest b/net-misc/stuntman/Manifest
new file mode 100644
index 000000000000..ee5634421574
--- /dev/null
+++ b/net-misc/stuntman/Manifest
@@ -0,0 +1,2 @@
+DIST stunserver-1.2.6.tgz 116056 SHA256 6d88792f6bba4be4a21227e1dbb58e5fad5bb36ce826352187d35451d9c6f58f SHA512 1d5f74d851308cf455795f9fcc80cdec687b4b1f6fa44477f13b7085c41a1c2eb8ab94578c71f9f00e4c830f3775d5d56f320247fd6b7d227a45e679ba784ef4 WHIRLPOOL 226c9520547102b6a49f227f97e00899d7f5d2c4775c32c8bea3dfa52659281fe97c41d6c384bd2adb102c64600391c20227c4698157223adc8b992a299d607b
+DIST stunserver-1.2.7.tgz 113853 SHA256 51415bf83339f059c6a65bbece9b758e3f198cb86063a0f1b4f12d825c87640e SHA512 b6adc1b237e8717f296201bf865bea39c759b978db954cc15e37c3be7c2e109607273d96bb88c42654d0b843ca1a557874d02ab58e16506534db30f52d7e6f51 WHIRLPOOL 67b19195b6f64420d9283241e7f51442b347020a55e46f405c3e875a6c59eca382bc680b3b17874a77df76ba8e64d1ecfa40367ef1713e83e96c25c4c6f441d1
diff --git a/net-misc/stuntman/files/initd.v1 b/net-misc/stuntman/files/initd.v1
new file mode 100644
index 000000000000..154d43e863b8
--- /dev/null
+++ b/net-misc/stuntman/files/initd.v1
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting STUNTMAN"
+ start-stop-daemon --start --quiet --exec /usr/sbin/stunserver \
+ --make-pidfile --pidfile=/run/stunserver.pid --background
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping STUNTMAN"
+ start-stop-daemon --stop --quiet --pidfile=/run/stunserver.pid
+ eend $?
+}
diff --git a/net-misc/stuntman/files/stuntman.confd b/net-misc/stuntman/files/stuntman.confd
new file mode 100644
index 000000000000..a49d512843e8
--- /dev/null
+++ b/net-misc/stuntman/files/stuntman.confd
@@ -0,0 +1,7 @@
+# Stuntman's stunserver normally starts in simple mode.
+# It's recommended to run stunserver in full mode, there are
+# basically two options, bind it to two separate interfaces,
+# or more conveniently, to IP addresses. There are numerous
+# other options for stunserver, just run stunserver --help
+# for more information.
+#STUNTMAN_PARAMS="--mode full --primaryinterface 1.2.3.4 --altinterface 1.2.3.5"
diff --git a/net-misc/stuntman/files/stuntman.initd b/net-misc/stuntman/files/stuntman.initd
new file mode 100644
index 000000000000..884f3d289b6e
--- /dev/null
+++ b/net-misc/stuntman/files/stuntman.initd
@@ -0,0 +1,13 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+pidfile="/run/stunserver.pid"
+command="/usr/sbin/stunserver"
+command_args="${STUNTMAN_PARAMS}"
+command_background="true"
+
+depend() {
+ need net
+}
diff --git a/net-misc/stuntman/metadata.xml b/net-misc/stuntman/metadata.xml
new file mode 100644
index 000000000000..3ed4669f55a4
--- /dev/null
+++ b/net-misc/stuntman/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/stuntman/stuntman-1.2.6-r1.ebuild b/net-misc/stuntman/stuntman-1.2.6-r1.ebuild
new file mode 100644
index 000000000000..2629dc7b6c4a
--- /dev/null
+++ b/net-misc/stuntman/stuntman-1.2.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="STUNTMAN is an open source implementation of the STUN protocol"
+HOMEPAGE="http://www.stunprotocol.org"
+SRC_URI="http://www.stunprotocol.org/stunserver-${PV}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/boost
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/stunserver"
+
+src_compile() {
+ emake T=""
+}
+
+src_install() {
+ dobin stunclient
+ dosbin stunserver
+ dodoc HISTORY README
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+src_test() {
+ ./stuntestcode
+}
diff --git a/net-misc/stuntman/stuntman-1.2.6.ebuild b/net-misc/stuntman/stuntman-1.2.6.ebuild
new file mode 100644
index 000000000000..8edb1947cfdf
--- /dev/null
+++ b/net-misc/stuntman/stuntman-1.2.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="STUNTMAN is an open source implementation of the STUN protocol"
+HOMEPAGE="http://www.stunprotocol.org"
+SRC_URI="http://www.stunprotocol.org/stunserver-${PV}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/boost
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/stunserver"
+
+src_compile()
+{
+ emake T=""
+}
+
+src_install()
+{
+ dobin stunclient
+ dosbin stunserver
+ dodoc HISTORY README
+ newinitd "${FILESDIR}/initd.v1" stuntman
+}
+
+src_test()
+{
+ ./stuntestcode
+}
diff --git a/net-misc/stuntman/stuntman-1.2.7.ebuild b/net-misc/stuntman/stuntman-1.2.7.ebuild
new file mode 100644
index 000000000000..7bb599de234f
--- /dev/null
+++ b/net-misc/stuntman/stuntman-1.2.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="STUNTMAN is an open source implementation of the STUN protocol"
+HOMEPAGE="http://www.stunprotocol.org"
+SRC_URI="http://www.stunprotocol.org/stunserver-${PV}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/boost
+ dev-libs/openssl:0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/stunserver"
+
+src_compile() {
+ emake T=""
+}
+
+src_install() {
+ dobin stunclient
+ dosbin stunserver
+ dodoc HISTORY README
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+src_test() {
+ ./stuntestcode
+}