summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/suite3270/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/suite3270/files')
-rw-r--r--net-misc/suite3270/files/Makefile.in10
-rw-r--r--net-misc/suite3270/files/configure-3.3.5.patch72
-rw-r--r--net-misc/suite3270/files/makeconv-3.3.5.patch79
-rw-r--r--net-misc/suite3270/files/suite3270-3.3.10_p3-fix-x3270-dbcs.patch20
4 files changed, 181 insertions, 0 deletions
diff --git a/net-misc/suite3270/files/Makefile.in b/net-misc/suite3270/files/Makefile.in
new file mode 100644
index 000000000000..154b470de801
--- /dev/null
+++ b/net-misc/suite3270/files/Makefile.in
@@ -0,0 +1,10 @@
+# DO NOT STARE AT THE SUN
+VER = @VER@
+_SUBDIRS = @SUBDIRS@
+SUBDIRS = $(_SUBDIRS:=-$(VER))
+all:
+%:; $(MAKE) `printf '%s_$@_ ' $(SUBDIRS)`
+_words = $(subst _, ,$1)
+_dir = $(firstword $(call _words,$@))
+_targ = $(lastword $(call _words,$@))
+%_:; $(MAKE) -C $(_dir) $(_targ) $(EXTRA_TARGETS)
diff --git a/net-misc/suite3270/files/configure-3.3.5.patch b/net-misc/suite3270/files/configure-3.3.5.patch
new file mode 100644
index 000000000000..e255ec68cfe8
--- /dev/null
+++ b/net-misc/suite3270/files/configure-3.3.5.patch
@@ -0,0 +1,72 @@
+From: Jesse Farinacci <jieryn@gmail.com>
+Date: 11 May 2007
+Gentoo-bug: 177042
+
+The configure scripts that build ICU need to include stdio.h.
+
+diff -Naur pr3287-3.3/configure pr3287-3.3/configure
+--- pr3287-3.3/configure 2007-05-11 12:22:27.622502551 -0400
++++ pr3287-3.3/configure 2007-05-11 12:24:16.842559358 -0400
+@@ -3134,6 +3134,7 @@
+ then echo "$as_me:$LINENO: checking for ICU version strings" >&5
+ echo $ECHO_N "checking for ICU version strings... $ECHO_C" >&6
+ cat >/tmp/icutst$$.c <<EOF
++#include <stdio.h>
+ #include "unicode/ucnv.h"
+ #define xstr(s) str(s)
+ #define str(s) #s
+diff -Naur pr3287-3.3/configure.in pr3287-3.3/configure.in
+--- pr3287-3.3/configure.in 2007-05-11 12:22:27.622502551 -0400
++++ pr3287-3.3/configure.in 2007-05-11 12:24:00.080240453 -0400
+@@ -146,6 +146,7 @@
+ if test "$enable_dbcs" != no
+ then AC_MSG_CHECKING([for ICU version strings])
+ cat >/tmp/icutst$$.c <<EOF
++#include <stdio.h>
+ #include "unicode/ucnv.h"
+ #define xstr(s) str(s)
+ #define str(s) #s
+diff -Naur s3270-3.3/configure s3270-3.3/configure
+--- s3270-3.3/configure 2007-05-11 12:22:27.619169419 -0400
++++ s3270-3.3/configure 2007-05-11 12:24:16.895889464 -0400
+@@ -3608,6 +3608,7 @@
+ then echo "$as_me:$LINENO: checking for ICU version strings" >&5
+ echo $ECHO_N "checking for ICU version strings... $ECHO_C" >&6
+ cat >/tmp/icutst$$.c <<EOF
++#include <stdio.h>
+ #include "unicode/ucnv.h"
+ #define xstr(s) str(s)
+ #define str(s) #s
+diff -Naur s3270-3.3/configure.in s3270-3.3/configure.in
+--- s3270-3.3/configure.in 2007-05-11 12:22:27.619169419 -0400
++++ s3270-3.3/configure.in 2007-05-11 12:24:00.080240453 -0400
+@@ -120,6 +120,7 @@
+ if test "$enable_dbcs" != no
+ then AC_MSG_CHECKING([for ICU version strings])
+ cat >/tmp/icutst$$.c <<EOF
++#include <stdio.h>
+ #include "unicode/ucnv.h"
+ #define xstr(s) str(s)
+ #define str(s) #s
+diff -Naur tcl3270-3.3/configure tcl3270-3.3/configure
+--- tcl3270-3.3/configure 2007-05-11 12:22:27.609170024 -0400
++++ tcl3270-3.3/configure 2007-05-11 12:24:16.902555727 -0400
+@@ -4234,6 +4234,7 @@
+ then echo "$as_me:$LINENO: checking for ICU version strings" >&5
+ echo $ECHO_N "checking for ICU version strings... $ECHO_C" >&6
+ cat >/tmp/icutst$$.c <<EOF
++#include <stdio.h>
+ #include "unicode/ucnv.h"
+ #define xstr(s) str(s)
+ #define str(s) #s
+diff -Naur tcl3270-3.3/configure.in tcl3270-3.3/configure.in
+--- tcl3270-3.3/configure.in 2007-05-11 12:22:27.605836893 -0400
++++ tcl3270-3.3/configure.in 2007-05-11 12:24:00.080240453 -0400
+@@ -149,6 +149,7 @@
+ if test "$enable_dbcs" != no
+ then AC_MSG_CHECKING([for ICU version strings])
+ cat >/tmp/icutst$$.c <<EOF
++#include <stdio.h>
+ #include "unicode/ucnv.h"
+ #define xstr(s) str(s)
+ #define str(s) #s
diff --git a/net-misc/suite3270/files/makeconv-3.3.5.patch b/net-misc/suite3270/files/makeconv-3.3.5.patch
new file mode 100644
index 000000000000..5076a1eeaae3
--- /dev/null
+++ b/net-misc/suite3270/files/makeconv-3.3.5.patch
@@ -0,0 +1,79 @@
+From: Jesse Farinacci <jieryn@gmail.com>
+Date: 11 May 2007
+Gentoo-bug: 177042
+
+Gentoo's makeconv does not have the -p PREFIX support, so do some mv work
+instead.
+
+--- c3270-3.3/Makefile.in 2007-02-25 10:53:17.566179262 +0100
++++ c3270-3.3/Makefile.in 2007-02-25 10:56:11.983434901 +0100
+@@ -67,13 +67,17 @@
+
+ @CNV@all:: $(ICU_CNV)
+ @CNV@$(IDP)_ibm-837_P100-2000.cnv: ibm-837_P100-2000.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-837_P100-2000.ucm
++@CNV@ makeconv -d . ibm-837_P100-2000.ucm
++@CNV@ mv ibm-837_P100-2000.cnv $(IDP)_ibm-837_P100-2000.cnv
+ @CNV@$(IDP)_ibm-300_P110-1997.cnv: ibm-300_P110-1997.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-300_P110-1997.ucm
++@CNV@ makeconv -d . ibm-300_P110-1997.ucm
++@CNV@ mv ibm-300_P110-1997.cnv $(IDP)_ibm-300_P110-1997.cnv
+ @CNV@$(IDP)_ibm-1027_P100-1995.cnv: ibm-1027_P100-1995.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-1027_P100-1995.ucm
++@CNV@ makeconv -d . ibm-1027_P100-1995.ucm
++@CNV@ mv ibm-1027_P100-1995.cnv $(IDP)_ibm-1027_P100-1995.cnv
+ @CNV@$(IDP)_ibm-1385_P100-1997.cnv: ibm-1385_P100-1997.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-1385_P100-1997.ucm
++@CNV@ makeconv -d . ibm-1385_P100-1997.ucm
++@CNV@ mv ibm-1385_P100-1997.cnv $(IDP)_ibm-1385_P100-1997.cnv
+
+ install:: c3270 x3270if
+ [ -d $(DESTDIR)$(BINDIR) ] || \
+--- s3270-3.3/Makefile.in 2007-02-25 11:19:35.987347863 +0100
++++ s3270-3.3/Makefile.in 2007-02-25 11:20:43.391134616 +0100
+@@ -64,13 +64,17 @@
+
+ @CNV@all:: $(ICU_CNV)
+ @CNV@$(IDP)_ibm-837_P100-2000.cnv: ibm-837_P100-2000.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-837_P100-2000.ucm
++@CNV@ makeconv -d . ibm-837_P100-2000.ucm
++@CNV@ mv ibm-837_P100-2000.cnv $(IDP)_ibm-837_P100-2000.cnv
+ @CNV@$(IDP)_ibm-300_P110-1997.cnv: ibm-300_P110-1997.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-300_P110-1997.ucm
++@CNV@ makeconv -d . ibm-300_P110-1997.ucm
++@CNV@ mv ibm-300_P110-1997.cnv $(IDP)_ibm-300_P110-1997.cnv
+ @CNV@$(IDP)_ibm-1027_P100-1995.cnv: ibm-1027_P100-1995.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-1027_P100-1995.ucm
++@CNV@ makeconv -d . ibm-1027_P100-1995.ucm
++@CNV@ mv ibm-1027_P100-1995.cnv $(IDP)_ibm-1027_P100-1995.cnv
+ @CNV@$(IDP)_ibm-1385_P100-1997.cnv: ibm-1385_P100-1997.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-1385_P100-1997.ucm
++@CNV@ makeconv -d . ibm-1385_P100-1997.ucm
++@CNV@ mv ibm-1385_P100-1997.cnv $(IDP)_ibm-1385_P100-1997.cnv
+
+ install:: s3270 x3270if
+ [ -d $(DESTDIR)$(BINDIR) ] || \
+--- tcl3270-3.3/Makefile.in 2007-02-25 11:21:30.416799814 +0100
++++ tcl3270-3.3/Makefile.in 2007-02-25 11:22:46.829756107 +0100
+@@ -63,13 +63,17 @@
+
+ @CNV@all:: $(ICU_CNV)
+ @CNV@$(IDP)_ibm-837_P100-2000.cnv: ibm-837_P100-2000.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-837_P100-2000.ucm
++@CNV@ makeconv -d . ibm-837_P100-2000.ucm
++@CNV@ mv ibm-837_P100-2000.cnv $(IDP)_ibm-837_P100-2000.cnv
+ @CNV@$(IDP)_ibm-300_P110-1997.cnv: ibm-300_P110-1997.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-300_P110-1997.ucm
++@CNV@ makeconv -d . ibm-300_P110-1997.ucm
++@CNV@ mv ibm-300_P110-1997.cnv $(IDP)_ibm-300_P110-1997.cnv
+ @CNV@$(IDP)_ibm-1027_P100-1995.cnv: ibm-1027_P100-1995.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-1027_P100-1995.ucm
++@CNV@ makeconv -d . ibm-1027_P100-1995.ucm
++@CNV@ mv ibm-1027_P100-1995.cnv $(IDP)_ibm-1027_P100-1995.cnv
+ @CNV@$(IDP)_ibm-1385_P100-1997.cnv: ibm-1385_P100-1997.ucm
+-@CNV@ makeconv -d . -p $(IDP) ibm-1385_P100-1997.ucm
++@CNV@ makeconv -d . ibm-1385_P100-1997.ucm
++@CNV@ mv ibm-1385_P100-1997.cnv $(IDP)_ibm-1385_P100-1997.cnv
+
+ install:: tcl3270
+ [ -d $(DESTDIR)$(BINDIR) ] || \
diff --git a/net-misc/suite3270/files/suite3270-3.3.10_p3-fix-x3270-dbcs.patch b/net-misc/suite3270/files/suite3270-3.3.10_p3-fix-x3270-dbcs.patch
new file mode 100644
index 000000000000..cfdc2778e98b
--- /dev/null
+++ b/net-misc/suite3270/files/suite3270-3.3.10_p3-fix-x3270-dbcs.patch
@@ -0,0 +1,20 @@
+# Patches were sent upstream to maintainer
+# as of 23 September 2009, by Jesse Farinacci <jieryn@gmail.com>
+
+--- x3270-3.3/screen.c
++++ x3270-3.3/screen.c
+@@ -2322,12 +2322,14 @@
+ void
+ screen_flip(void)
+ {
++#if defined(X3270_DBCS) /*[*/
+ /* Flip mode is broken in the DBCS version. */
+ if (!dbcs) {
+ flipped = !flipped;
+
+ action_internal(PA_Expose_action, IA_REDRAW, CN, CN);
+ }
++#endif /*]*/
+ }
+
+ /*