summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/suite3270/suite3270-3.3.13_p7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/suite3270/suite3270-3.3.13_p7.ebuild')
-rw-r--r--net-misc/suite3270/suite3270-3.3.13_p7.ebuild114
1 files changed, 114 insertions, 0 deletions
diff --git a/net-misc/suite3270/suite3270-3.3.13_p7.ebuild b/net-misc/suite3270/suite3270-3.3.13_p7.ebuild
new file mode 100644
index 000000000000..9c4ee86d5b40
--- /dev/null
+++ b/net-misc/suite3270/suite3270-3.3.13_p7.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+MY_PV=${PV/_p/ga}
+MY_P=${PN}-${MY_PV}
+SUB_PV=${PV:0:3}
+
+S=${WORKDIR}
+
+# only the x3270 package installs fonts
+FONT_PN="x3270"
+FONT_S=${WORKDIR}/${FONT_PN}-${SUB_PV}
+
+inherit eutils font multiprocessing
+
+DESCRIPTION="Complete 3270 access package"
+HOMEPAGE="http://x3270.bgp.nu/"
+SRC_URI="mirror://sourceforge/x3270/${MY_P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE="cjk doc ncurses ssl tcl X"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ )
+ ncurses? ( sys-libs/ncurses sys-libs/readline )
+ tcl? ( dev-lang/tcl:0 )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-misc/xbitmaps
+ x11-proto/xproto
+ app-text/rman
+ x11-apps/mkfontdir
+ x11-apps/bdftopcf
+ )"
+
+suite3270_makelist() {
+ echo pr3287 s3270 \
+ $(usex ncurses c3270 '') \
+ $(usex tcl tcl3270 '') \
+ $(usex X x3270 '')
+}
+
+src_prepare() {
+ # Some subdirs (like c3270/x3270/s3270) install the same set of data files
+ # (they have the same contents). Wrap that in a retry to avoid errors.
+ cat <<-EOF > _install
+ #!/bin/sh
+ for n in {1..5}; do
+ install "\$@" && exit
+ echo "retrying ..."
+ done
+ EOF
+ chmod a+rx _install
+ sed -i \
+ -e "s:@INSTALL@:${S}/_install:" \
+ */Makefile.in
+}
+
+src_configure() {
+ local p myconf
+ # Run configures in parallel!
+ multijob_init
+ for p in $(suite3270_makelist) ; do
+ cd "${S}/${p}-${SUB_PV}"
+ if [[ ${p} == "x3270" ]] ; then
+ myconf=(
+ --without-xmkmf
+ $(use_with X x)
+ $(use_with X fontdir "${FONTDIR}")
+ )
+ else
+ myconf=()
+ fi
+ multijob_child_init econf \
+ --cache-file="${S}"/config.cache \
+ $(use_enable cjk dbcs) \
+ $(use_enable ssl) \
+ "${myconf[@]}"
+ done
+ sed \
+ -e "s:@SUBDIRS@:$(suite3270_makelist):" \
+ -e "s:@VER@:${SUB_PV}:" \
+ "${FILESDIR}"/Makefile.in > "${S}"/Makefile || die
+ multijob_finish
+}
+
+src_install() {
+ use X && dodir "${FONTDIR}"
+ EXTRA_TARGETS='install.man' default
+ local p
+ for p in $(suite3270_makelist) ; do
+ cd "${S}/${p}-${SUB_PV}"
+ docinto ${p}
+ local d=$(echo README*)
+ [[ -n ${d} ]] && dodoc ${d}
+ use doc && dohtml html/*
+ done
+ find "${ED}"/usr/share/man/ -type f -exec chmod a-x {} +
+
+ use X && font_src_install
+}
+
+pkg_postinst() { use X && font_pkg_postinst ; }
+pkg_postrm() { use X && font_pkg_postrm ; }