summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/suite3270/suite3270-3.3.7_p8.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/suite3270/suite3270-3.3.7_p8.ebuild')
-rw-r--r--net-misc/suite3270/suite3270-3.3.7_p8.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/net-misc/suite3270/suite3270-3.3.7_p8.ebuild b/net-misc/suite3270/suite3270-3.3.7_p8.ebuild
new file mode 100644
index 000000000000..266510fd63e8
--- /dev/null
+++ b/net-misc/suite3270/suite3270-3.3.7_p8.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE="cjk doc ncurses ssl tcl X"
+
+S="${WORKDIR}"
+DESCRIPTION="Complete 3270 access package"
+SRC_URI="http://x3270.bgp.nu/download/${PN}-${PV/_/}.tgz"
+HOMEPAGE="http://x3270.bgp.nu/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+
+RDEPEND="X? ( x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt )
+ cjk? ( dev-libs/icu )
+ ncurses? ( sys-libs/ncurses
+ sys-libs/readline )
+ ssl? ( dev-libs/openssl )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-misc/imake
+ x11-misc/xbitmaps
+ x11-proto/xproto
+ app-text/rman
+ x11-apps/mkfontdir
+ x11-apps/bdftopcf )"
+
+SUB_PV="3.3"
+MY_FONTDIR="/usr/share/fonts/x3270"
+
+suite3270_makelist() {
+ MY_PLIST="pr3287 s3270"
+ use ncurses && MY_PLIST="${MY_PLIST} c3270"
+ use tcl && MY_PLIST="${MY_PLIST} tcl3270"
+ use X && MY_PLIST="${MY_PLIST} x3270"
+}
+
+src_compile() {
+ local myconf
+
+ myconf="--without-pr3287"
+ myconf="${myconf} --cache-file=${S}/config.cache"
+ myconf="${myconf} $(use_enable cjk dbcs)"
+ myconf="${myconf} $(use_enable ssl)"
+ myconf="${myconf} $(use_with X x)"
+ myconf="${myconf} $(use_with X fontdir ${MY_FONTDIR})"
+
+ suite3270_makelist
+ for p in ${MY_PLIST} ; do
+ cd "${S}/${p}-${SUB_PV}"
+ econf ${myconf} || die "econf failed on ${p}"
+ emake || die "emake faild on ${p}"
+ done
+}
+
+src_install () {
+ suite3270_makelist
+ use X && dodir ${MY_FONTDIR}
+ for p in ${MY_PLIST} ; do
+ cd "${S}/${p}-${SUB_PV}"
+ emake DESTDIR="${D}" install install.man \
+ || die "emake failed on ${p}"
+ use doc && docinto ${p} && dohtml html/*
+ done
+
+ use X && rm -f "${D}/${MY_FONTDIR}/fonts.dir"
+ return 0
+}
+
+pkg_postinst() {
+ if use X ; then
+ einfo "Running mkfontdir on ${MY_FONTDIR}"
+ mkfontdir ${MY_FONTDIR}
+ fi
+}