summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-03-01 23:21:39 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-03-01 23:31:29 +0000
commitc7915a37767f37dc8256568f440355d9e1e33e53 (patch)
tree16f99b522564b69a2dd392e5968d3c406fb0612e /net-misc/sunshine/sunshine-0.21.0.ebuild
parentdev-util/diffoscope: add 259 (diff)
downloadgentoo-c7915a37767f37dc8256568f440355d9e1e33e53.tar.gz
gentoo-c7915a37767f37dc8256568f440355d9e1e33e53.tar.bz2
gentoo-c7915a37767f37dc8256568f440355d9e1e33e53.zip
net-misc/sunshine: Fix cross-compiling with patch
Upstream say they will merge this in time for the next release. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-misc/sunshine/sunshine-0.21.0.ebuild')
-rw-r--r--net-misc/sunshine/sunshine-0.21.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-misc/sunshine/sunshine-0.21.0.ebuild b/net-misc/sunshine/sunshine-0.21.0.ebuild
index 22cf946e4348..1c21649b7929 100644
--- a/net-misc/sunshine/sunshine-0.21.0.ebuild
+++ b/net-misc/sunshine/sunshine-0.21.0.ebuild
@@ -237,6 +237,10 @@ src_unpack() {
}
src_prepare() {
+ # Apply CBS patch.
+ cd "${WORKDIR}"/build-deps || die
+ eapply "${FILESDIR}"/${PN}-cross-cbs.patch
+
# Apply general ffmpeg patches.
cd "${WORKDIR}"/build-deps/ffmpeg_sources/ffmpeg || die
eapply "${WORKDIR}"/build-deps/ffmpeg_patches/ffmpeg/*.patch
@@ -329,8 +333,6 @@ src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=no
-DCMAKE_INSTALL_PREFIX="${S}"/third-party/ffmpeg
- $(usex arm64 -DCROSS_COMPILE_ARM=yes "")
- $(usex ppc64 -DCROSS_COMPILE_PPC=yes "")
)
CMAKE_USE_DIR="${WORKDIR}/build-deps" cmake_src_configure