summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-12-12 18:57:24 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-12-12 18:57:24 +0100
commit677f04204506a16005a725f3ff57175059635ea9 (patch)
treeabbad03672c62e35708b0afcbd9ecea6d3b4d83f /net-misc/sysrepo
parentdev-libs/libbpf: add 0.6.1 (diff)
downloadgentoo-677f04204506a16005a725f3ff57175059635ea9.tar.gz
gentoo-677f04204506a16005a725f3ff57175059635ea9.tar.bz2
gentoo-677f04204506a16005a725f3ff57175059635ea9.zip
net-misc/sysrepo: Add missing sys/stat.h include for musl
Closes: https://bugs.gentoo.org/828916 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-misc/sysrepo')
-rw-r--r--net-misc/sysrepo/files/sysrepo-2.0.53-musl.patch11
-rw-r--r--net-misc/sysrepo/sysrepo-2.0.53.ebuild4
2 files changed, 15 insertions, 0 deletions
diff --git a/net-misc/sysrepo/files/sysrepo-2.0.53-musl.patch b/net-misc/sysrepo/files/sysrepo-2.0.53-musl.patch
new file mode 100644
index 000000000000..24c5d86edc59
--- /dev/null
+++ b/net-misc/sysrepo/files/sysrepo-2.0.53-musl.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/828916
+--- a/src/sysrepo_types.h
++++ b/src/sysrepo_types.h
+@@ -19,6 +19,7 @@
+
+ #include <inttypes.h>
+ #include <stddef.h>
++#include <sys/stat.h>
+
+ struct lyd_node;
+ struct timespec;
diff --git a/net-misc/sysrepo/sysrepo-2.0.53.ebuild b/net-misc/sysrepo/sysrepo-2.0.53.ebuild
index 622f5a98a45b..4f3809b892f7 100644
--- a/net-misc/sysrepo/sysrepo-2.0.53.ebuild
+++ b/net-misc/sysrepo/sysrepo-2.0.53.ebuild
@@ -19,6 +19,10 @@ RDEPEND=">=net-libs/libyang-2.0.112:="
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
+PATCHES=(
+ "${FILESDIR}"/${P}-musl.patch
+)
+
src_configure() {
local mycmakeargs=(
-DENABLE_TESTS=$(usex test)