summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/taylor-uucp/taylor-uucp-1.07-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/taylor-uucp/taylor-uucp-1.07-r2.ebuild')
-rw-r--r--net-misc/taylor-uucp/taylor-uucp-1.07-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/taylor-uucp/taylor-uucp-1.07-r2.ebuild b/net-misc/taylor-uucp/taylor-uucp-1.07-r2.ebuild
new file mode 100644
index 000000000000..3fb6d932e8ec
--- /dev/null
+++ b/net-misc/taylor-uucp/taylor-uucp-1.07-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="Taylor UUCP"
+HOMEPAGE="http://www.airs.com/ian/uucp.html"
+SRC_URI="mirror://gnu/uucp/uucp-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc sparc x86"
+IUSE=""
+
+S="${WORKDIR}/uucp-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ mv configure.{in,ac} || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -D_GNU_SOURCE -fno-strict-aliasing
+ econf --with-newconfigdir=/etc/uucp
+}
+
+src_install() {
+ dodir /usr/share/man/man{1,8}
+ dodir /usr/share/info
+ dodir /etc/uucp
+ dodir /usr/bin /usr/sbin
+ diropts -o uucp -g uucp -m 0750
+ keepdir /var/log/uucp /var/spool/uucp
+ diropts -o uucp -g uucp -m 0775
+ keepdir /var/spool/uucppublic
+
+ emake \
+ "prefix=${D}/usr" \
+ "sbindir=${D}/usr/sbin" \
+ "bindir=${D}/usr/bin" \
+ "man1dir=${D}/usr/share/man/man1" \
+ "man8dir=${D}/usr/share/man/man8" \
+ "newconfigdir=${D}/etc/uucp" \
+ "infodir=${D}/usr/share/info" \
+ install install-info
+ sed -i -e 's:/usr/spool:/var/spool:g' sample/config
+ cp sample/* "${ED}/etc/uucp" || die
+ dodoc ChangeLog NEWS README TODO
+}
+
+pkg_preinst() {
+ usermod -s /bin/bash uucp
+}