summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-07-26 13:27:53 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-07-26 13:28:50 +0300
commita6c6818867d131da07cb18d5b568b3d0f8a240ec (patch)
treeccc67f0bfc1e43f5ed3a331e23edb9bda42c4352 /net-misc/tokyotyrant
parentnet-irc/znc: remove slash strip from EAPI=7 ebuilds (diff)
downloadgentoo-a6c6818867d131da07cb18d5b568b3d0f8a240ec.tar.gz
gentoo-a6c6818867d131da07cb18d5b568b3d0f8a240ec.tar.bz2
gentoo-a6c6818867d131da07cb18d5b568b3d0f8a240ec.zip
net-misc/tokyotyrant: bump to EAPI=7
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-misc/tokyotyrant')
-rw-r--r--net-misc/tokyotyrant/files/fix_testsuite.patch4
-rw-r--r--net-misc/tokyotyrant/tokyotyrant-1.1.41-r2.ebuild (renamed from net-misc/tokyotyrant/tokyotyrant-1.1.41-r1.ebuild)28
2 files changed, 16 insertions, 16 deletions
diff --git a/net-misc/tokyotyrant/files/fix_testsuite.patch b/net-misc/tokyotyrant/files/fix_testsuite.patch
index d48825381777..7ee9dc801cb6 100644
--- a/net-misc/tokyotyrant/files/fix_testsuite.patch
+++ b/net-misc/tokyotyrant/files/fix_testsuite.patch
@@ -1,5 +1,5 @@
---- Makefile.in 2009-10-14 10:33:16.000000000 +0200
-+++ Makefile.in.new 2009-10-14 10:27:39.000000000 +0200
+--- a/Makefile.in 2009-10-14 10:33:16.000000000 +0200
++++ b/Makefile.in.new 2009-10-14 10:27:39.000000000 +0200
@@ -166,48 +166,49 @@
diff --git a/net-misc/tokyotyrant/tokyotyrant-1.1.41-r1.ebuild b/net-misc/tokyotyrant/tokyotyrant-1.1.41-r2.ebuild
index 3aebae8184ac..1da7a34c2009 100644
--- a/net-misc/tokyotyrant/tokyotyrant-1.1.41-r1.ebuild
+++ b/net-misc/tokyotyrant/tokyotyrant-1.1.41-r2.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=7
-inherit eutils user
+inherit user
DESCRIPTION="A network interface to Tokyo Cabinet"
-HOMEPAGE="http://fallabs.com/tokyotyrant/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
+HOMEPAGE="https://fallabs.com/tokyotyrant/"
+SRC_URI="https://fallabs.com/tokyotyrant/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -16,7 +16,6 @@ IUSE="debug examples lua"
DEPEND="dev-db/tokyocabinet
sys-libs/zlib
- app-arch/bzip2
lua? ( dev-lang/lua )"
RDEPEND="${DEPEND}"
@@ -28,8 +27,9 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/fix_makefiles-1.4.41.patch
- epatch "${FILESDIR}"/fix_testsuite.patch
+ default
+ eapply "${FILESDIR}"/fix_makefiles-1.4.41.patch
+ eapply "${FILESDIR}"/fix_testsuite.patch
}
src_configure() {
@@ -40,7 +40,7 @@ src_configure() {
src_install() {
rm ttservctl || die "Install failed"
- emake DESTDIR="${D}" install || die "Install failed"
+ default
for x in /var/{lib,run,log}/${PN}; do
dodir "${x}" || die "Install failed"
@@ -49,16 +49,16 @@ src_install() {
if use examples; then
insinto /usr/share/${PF}/example
- doins example/* || die "Install failed"
+ doins -r example/
fi
- dohtml doc/* || die
+ dodoc -r doc
- newinitd "${FILESDIR}/${PN}.initd" ${PN} || die "Install failed"
- newconfd "${FILESDIR}/${PN}.confd" ${PN} || die "Install failed"
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
}
src_test() {
- emake -j1 check || die "Tests failed"
+ emake -j1 check
}