summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/urlview/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/urlview/files')
-rw-r--r--net-misc/urlview/files/include-fix.patch11
-rw-r--r--net-misc/urlview/files/no-trailing-newline.patch11
-rw-r--r--net-misc/urlview/files/urlview-0.9-DESTDIR.patch23
-rw-r--r--net-misc/urlview/files/urlview-0.9-tinfo.patch21
4 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/urlview/files/include-fix.patch b/net-misc/urlview/files/include-fix.patch
new file mode 100644
index 000000000000..b9bb6ab46992
--- /dev/null
+++ b/net-misc/urlview/files/include-fix.patch
@@ -0,0 +1,11 @@
+--- a/urlview.c
++++ b/urlview.c
+@@ -40,6 +40,8 @@
+ #include <fcntl.h>
+ #include <sys/stat.h>
+
++#include "quote.h"
++
+ #ifdef HAVE_REGEX_H
+ #include <regex.h>
+ #else
diff --git a/net-misc/urlview/files/no-trailing-newline.patch b/net-misc/urlview/files/no-trailing-newline.patch
new file mode 100644
index 000000000000..6d78cd4ed073
--- /dev/null
+++ b/net-misc/urlview/files/no-trailing-newline.patch
@@ -0,0 +1,11 @@
+--- a/urlview.c
++++ b/urlview.no-trailing-newline.c
+@@ -46,7 +46,7 @@
+ #include <rx/rxposix.h>
+ #endif
+
+-#define DEFAULT_REGEXP "(((https?|ftp|gopher)://|(mailto|file|news):)[^' \t<>\"]+|(www|web|w3)\\.[-a-z0-9.]+)[^' \t.,;<>\"\\):]"
++#define DEFAULT_REGEXP "(((https?|ftp|gopher)://|(mailto|file|news):)[^' \t<>\"]+|(www|web|w3)\\.[-a-z0-9.]+)[^' \n\t.,;<>\"\\):]"
+ #define DEFAULT_COMMAND "url_handler.sh %s"
+ #define SYSTEM_INITFILE "/etc/urlview.conf"
+
diff --git a/net-misc/urlview/files/urlview-0.9-DESTDIR.patch b/net-misc/urlview/files/urlview-0.9-DESTDIR.patch
new file mode 100644
index 000000000000..8c4cfe816b63
--- /dev/null
+++ b/net-misc/urlview/files/urlview-0.9-DESTDIR.patch
@@ -0,0 +1,23 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -11,6 +11,7 @@
+ CLEANFILES = *~ *.orig *.rej
+
+ install-data-local:
+- $(INSTALL_DATA) urlview.man $(mandir)/man1/urlview.1
++ $(mkinstalldirs) $(DESTDIR)$(mandir)/man1
++ $(INSTALL_DATA) urlview.man ${DESTDIR}$(mandir)/man1/urlview.1
+
+ # how to create a target for uninstall-data-local???
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -318,7 +318,8 @@
+
+
+ install-data-local:
+- $(INSTALL_DATA) urlview.man $(mandir)/man1/urlview.1
++ $(mkinstalldirs) $(DESTDIR)$(mandir)/man1
++ $(INSTALL_DATA) urlview.man $(DESTDIR)$(mandir)/man1/urlview.1
+
+ # how to create a target for uninstall-data-local???
+
diff --git a/net-misc/urlview/files/urlview-0.9-tinfo.patch b/net-misc/urlview/files/urlview-0.9-tinfo.patch
new file mode 100644
index 000000000000..e8f3886a4d0e
--- /dev/null
+++ b/net-misc/urlview/files/urlview-0.9-tinfo.patch
@@ -0,0 +1,21 @@
+--- a/configure.in
++++ b/configure.in
+@@ -3,6 +3,8 @@
+ dnl AM_CONFIG_HEADER(config.h)
+ AM_PROG_CC_STDC
+ CFLAGS="$CFLAGS -DURLVIEW -Dunix"
++
++PKG_CHECK_MODULES(ncurses,ncurses)
+ AC_ARG_WITH(slang, [ --with-slang[=DIR] use S-Lang instead of curses],
+ [AC_DEFINE(USE_SLANG)
+ if test $withval = yes -a -d ../slang; then
+@@ -22,8 +24,7 @@
+ fi
+ LIBS="$LIBS -lslang -lm"
+ fi],
+-
+- [AC_CHECK_LIB(ncurses, initscr, [LIBS="$LIBS -lncurses"], [LIBS="$LIBS -lcurses"])
++ [LIBS="$LIBS $ncurses_LIBS"
+ AC_CHECK_FUNCS(curs_set)
+ AC_CHECK_HEADERS(ncurses.h)
+ AC_CHECK_HEADER(ncurses/curses.h, [CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"])])