summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-29 00:08:57 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-29 00:08:57 +0100
commit312fbb322f44b3023a33e93f7c5a2eda32636a5c (patch)
tree6527b623fe8c45415c215417c72fae9e08bb0160 /net-misc/usbip
parentmedia-tv/w_scan: port to EAPI 7 (diff)
downloadgentoo-312fbb322f44b3023a33e93f7c5a2eda32636a5c.tar.gz
gentoo-312fbb322f44b3023a33e93f7c5a2eda32636a5c.tar.bz2
gentoo-312fbb322f44b3023a33e93f7c5a2eda32636a5c.zip
net-misc/usbip: fix build with gcc-10
* Unconditionally disable static-libs * Thanks to Jeroen Roovers for submitting the patch Closes: https://bugs.gentoo.org/707222 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/usbip')
-rw-r--r--net-misc/usbip/files/usbip-4.13-fno-common.patch44
-rw-r--r--net-misc/usbip/usbip-4.13-r1.ebuild (renamed from net-misc/usbip/usbip-4.13.ebuild)22
2 files changed, 55 insertions, 11 deletions
diff --git a/net-misc/usbip/files/usbip-4.13-fno-common.patch b/net-misc/usbip/files/usbip-4.13-fno-common.patch
new file mode 100644
index 000000000000..b8ffc40c4b9e
--- /dev/null
+++ b/net-misc/usbip/files/usbip-4.13-fno-common.patch
@@ -0,0 +1,44 @@
+--- a/libsrc/usbip_common.c
++++ b/libsrc/usbip_common.c
+@@ -14,7 +14,7 @@
+ int usbip_use_stderr;
+ int usbip_use_debug;
+
+-extern struct udev *udev_context;
++struct udev *udev_context;
+
+ struct speed_string {
+ int num;
+--- alibsrc/usbip_common.h
++++ b/libsrc/usbip_common.h
+@@ -53,6 +53,8 @@
+ #define ST_NODEV 0x04
+ #define ST_ERROR 0x05
+
++extern struct udev *udev_context;
++
+ extern int usbip_use_syslog;
+ extern int usbip_use_stderr;
+ extern int usbip_use_debug ;
+--- a/libsrc/usbip_host_common.c
++++ b/libsrc/usbip_host_common.c
+@@ -23,8 +23,6 @@
+ #include "list.h"
+ #include "sysfs_utils.h"
+
+-struct udev *udev_context;
+-
+ static int32_t read_attr_usbip_status(struct usbip_usb_device *udev)
+ {
+ char status_attr_path[SYSFS_PATH_MAX];
+--- a/libsrc/vhci_driver.c
++++ b/libsrc/vhci_driver.c
+@@ -15,7 +15,6 @@
+ #define PROGNAME "libusbip"
+
+ struct usbip_vhci_driver *vhci_driver;
+-struct udev *udev_context;
+
+ static struct usbip_imported_device *
+ imported_device_init(struct usbip_imported_device *idev, char *busid)
+
diff --git a/net-misc/usbip/usbip-4.13.ebuild b/net-misc/usbip/usbip-4.13-r1.ebuild
index bfb8473198b7..453bd87fa8fd 100644
--- a/net-misc/usbip/usbip-4.13.ebuild
+++ b/net-misc/usbip/usbip-4.13-r1.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
ETYPE="sources"
K_NOUSENAME=1
-inherit autotools eutils kernel-2 ltprune
+inherit autotools kernel-2
DESCRIPTION="Userspace utilities for a general USB device sharing system over IP networks"
HOMEPAGE="https://www.kernel.org/"
@@ -13,10 +14,10 @@ SRC_URI="${KERNEL_URI}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static-libs tcpd"
-RESTRICT=""
+IUSE="tcpd"
-RDEPEND=">=dev-libs/glib-2.6
+RDEPEND="
+ >=dev-libs/glib-2.6
sys-apps/hwids
>=sys-kernel/linux-headers-3.17
virtual/libudev
@@ -24,33 +25,32 @@ RDEPEND=">=dev-libs/glib-2.6
DEPEND="${RDEPEND}
virtual/pkgconfig"
-DOCS="AUTHORS README"
+S="${WORKDIR}/linux-${PV}/tools/usb/${PN}"
-S=${WORKDIR}/linux-${PV}/tools/usb/${PN}
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_unpack() {
tar xJf "${DISTDIR}"/${A} linux-${PV}/tools/usb/${PN} || die
}
src_prepare() {
+ default
# remove -Werror from build, bug #545398
sed -i 's/-Werror[^ ]* //g' configure.ac || die
- default
-
eautoreconf
}
src_configure() {
econf \
- $(use_enable static-libs static) \
+ --disable-static \
$(use tcpd || echo --without-tcp-wrappers) \
- --with-usbids-dir=/usr/share/misc
+ --with-usbids-dir="${EPREFIX}"/usr/share/misc
}
src_install() {
default
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {