summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-04-23 21:06:25 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-23 21:06:25 -0400
commit8edc61b33e6167b8db41aff4f649150ba98f3763 (patch)
tree3b96cb7a413facc961cbc7667479bf4becfa099d /net-misc/vde/vde-2.3.2-r6.ebuild
parentnet-misc/vde: Fix typos (diff)
downloadgentoo-8edc61b33e6167b8db41aff4f649150ba98f3763.tar.gz
gentoo-8edc61b33e6167b8db41aff4f649150ba98f3763.tar.bz2
gentoo-8edc61b33e6167b8db41aff4f649150ba98f3763.zip
net-misc/vde: Swap out Mandriva patch for upstream backport
Package-Manager: Portage-2.3.96, Repoman-2.3.21 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'net-misc/vde/vde-2.3.2-r6.ebuild')
-rw-r--r--net-misc/vde/vde-2.3.2-r6.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/vde/vde-2.3.2-r6.ebuild b/net-misc/vde/vde-2.3.2-r6.ebuild
new file mode 100644
index 000000000000..c872dce076b1
--- /dev/null
+++ b/net-misc/vde/vde-2.3.2-r6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="Virtual distributed ethernet emulator for emulators like qemu, bochs, and uml"
+SRC_URI="mirror://sourceforge/vde/${MY_P}.tar.bz2"
+HOMEPAGE="https://virtualsquare.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="pcap python selinux ssl libressl static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPS="pcap? ( net-libs/libpcap )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${COMMON_DEPS}"
+RDEPEND="${COMMON_DEPS}
+ acct-group/qemu
+ selinux? ( sec-policy/selinux-vde )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-format-security.patch"
+ "${FILESDIR}/${P}-fix-inline-funcs-r1.patch"
+)
+
+src_prepare() {
+ default
+ has_version ">=dev-libs/openssl-1.1.0" && eapply "${FILESDIR}/${P}-openssl-1.1.patch"
+}
+
+src_configure() {
+ econf \
+ --disable-python
+ $(use_enable pcap) \
+ $(use_enable ssl cryptcab) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+
+ newinitd "${FILESDIR}"/vde.init-r1 vde
+ newconfd "${FILESDIR}"/vde.conf-r1 vde
+}
+
+pkg_postinst() {
+ einfo "To start vde automatically add it to the default runlevel:"
+ einfo "# rc-update add vde default"
+ einfo "You need to setup tap0 in /etc/conf.d/net"
+ einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
+}