summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/vncrec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/vncrec')
-rw-r--r--net-misc/vncrec/Manifest1
-rw-r--r--net-misc/vncrec/files/vncrec-0.2-includes.patch21
-rw-r--r--net-misc/vncrec/metadata.xml7
-rw-r--r--net-misc/vncrec/vncrec-0.2-r1.ebuild50
4 files changed, 79 insertions, 0 deletions
diff --git a/net-misc/vncrec/Manifest b/net-misc/vncrec/Manifest
new file mode 100644
index 000000000000..1818d83a1403
--- /dev/null
+++ b/net-misc/vncrec/Manifest
@@ -0,0 +1 @@
+DIST vncrec-0.2.tar.gz 65768 SHA256 fd4abed79892c68c078d74ec9cd7599d782325f5f59b71f356aec0120c21295b
diff --git a/net-misc/vncrec/files/vncrec-0.2-includes.patch b/net-misc/vncrec/files/vncrec-0.2-includes.patch
new file mode 100644
index 000000000000..174a42738ab7
--- /dev/null
+++ b/net-misc/vncrec/files/vncrec-0.2-includes.patch
@@ -0,0 +1,21 @@
+--- a/vncconnect/vncconnect.c 2001-06-09 05:41:45.000000000 +0200
++++ b/vncconnect/vncconnect.c 2010-09-28 20:19:03.000000000 +0200
+@@ -5,6 +5,8 @@
+ #include <stdio.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xatom.h>
++#include <stdlib.h> /* exit() */
++#include <string.h> /* strlen() */
+
+ static char *programName;
+
+--- a/libvncauth/vncauth.c 2001-06-09 05:41:45.000000000 +0200
++++ b/libvncauth/vncauth.c 2010-09-28 20:19:44.000000000 +0200
+@@ -28,6 +28,7 @@
+ #include <sys/stat.h>
+ #include <vncauth.h>
+ #include <d3des.h>
++#include <time.h> /* time() */
+
+
+ /*
diff --git a/net-misc/vncrec/metadata.xml b/net-misc/vncrec/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/net-misc/vncrec/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/vncrec/vncrec-0.2-r1.ebuild b/net-misc/vncrec/vncrec-0.2-r1.ebuild
new file mode 100644
index 000000000000..c27089273247
--- /dev/null
+++ b/net-misc/vncrec/vncrec-0.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="VNC session recorder and player"
+HOMEPAGE="http://www.sodan.org/~penny/vncrec/"
+SRC_URI="http://www.sodan.org/~penny/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXpm
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-misc/imake
+ x11-proto/xextproto"
+
+DOCS=( README README.vnc )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-includes.patch
+ touch vncrec/vncrec.man || die
+ sed -i Imakefile \
+ -e '/make Makefiles/d' \
+ || die "sed Imakefile"
+}
+
+src_configure() {
+ xmkmf -a || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CCOPTIONS="${CXXFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ World
+}