summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-03-16 08:36:25 -0500
committerBen Kohler <bkohler@gentoo.org>2020-03-16 08:40:44 -0500
commit790d0e99059731aaa94ef3bf3ae80837bb17859a (patch)
tree311708a620adec274b94a255887bb34e688a4c3c /net-misc/wakeonlan/wakeonlan-0.41-r3.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to 4.19.110 - remove old. (diff)
downloadgentoo-790d0e99059731aaa94ef3bf3ae80837bb17859a.tar.gz
gentoo-790d0e99059731aaa94ef3bf3ae80837bb17859a.tar.bz2
gentoo-790d0e99059731aaa94ef3bf3ae80837bb17859a.zip
net-misc/wakeonlan: revbump with new homepage & other fixes
Closes: https://bugs.gentoo.org/612406 Closes: https://bugs.gentoo.org/554366 Closes: https://bugs.gentoo.org/569900 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/wakeonlan/wakeonlan-0.41-r3.ebuild')
-rw-r--r--net-misc/wakeonlan/wakeonlan-0.41-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/wakeonlan/wakeonlan-0.41-r3.ebuild b/net-misc/wakeonlan/wakeonlan-0.41-r3.ebuild
new file mode 100644
index 000000000000..c61e6f722759
--- /dev/null
+++ b/net-misc/wakeonlan/wakeonlan-0.41-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GENTOO_DEPEND_ON_PERL=noslotop
+inherit perl-module
+
+DESCRIPTION="Client for Wake-On-LAN"
+HOMEPAGE="https://github.com/jpoliv/wakeonlan/"
+SRC_URI="https://github.com/jpoliv/wakeonlan/archive/${P}.tar.gz"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+PATCHES="${FILESDIR}/${P}-ethers-lookup-r1.patch"
+
+src_install() {
+ perl-module_src_install
+ dodoc examples/lab001.wol
+ fperms u+w /usr/bin/wakeonlan /usr/share/man/man1/wakeonlan.1
+}