summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-15 14:12:32 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-15 14:12:32 -0400
commit507e6ca03e82b1a7765c3b69572551c119417cf7 (patch)
treebac0361eefad154df1ca6c2ec161f4dfe6b093db /net-misc/wget
parentdev-db/mysql-connector-c: Revert accidental stable keyword for ppc64 (diff)
downloadgentoo-507e6ca03e82b1a7765c3b69572551c119417cf7.tar.gz
gentoo-507e6ca03e82b1a7765c3b69572551c119417cf7.tar.bz2
gentoo-507e6ca03e82b1a7765c3b69572551c119417cf7.zip
net-misc/wget: rework patch to not trigger automake #560568
Basically we drop the new test since it patches the Makefile.am which in turn would require regenerating autotools (which we don't do now). It's not a big loss either.
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/files/wget-1.16.3-ftp-pasv-ip.patch99
1 files changed, 0 insertions, 99 deletions
diff --git a/net-misc/wget/files/wget-1.16.3-ftp-pasv-ip.patch b/net-misc/wget/files/wget-1.16.3-ftp-pasv-ip.patch
index 566350283e5c..9936f1ee1922 100644
--- a/net-misc/wget/files/wget-1.16.3-ftp-pasv-ip.patch
+++ b/net-misc/wget/files/wget-1.16.3-ftp-pasv-ip.patch
@@ -71,105 +71,6 @@ index 68f1a33..9dab99c 100644
{
/* Wait for the server to connect to the address we're waiting
at. */
-diff --git a/tests/FTPServer.pm b/tests/FTPServer.pm
-index c0a6e47..a5185d6 100644
---- a/tests/FTPServer.pm
-+++ b/tests/FTPServer.pm
-@@ -740,6 +740,14 @@ sub run
- last;
- }
-
-+ if (defined($self->{_server_behavior}{pasv_not_supported})
-+ && $cmd eq 'PASV')
-+ {
-+ print {$conn->{socket}}
-+ "500 PASV not supported.\r\n";
-+ next;
-+ }
-+
- # Run the command.
- &{$command_table->{$cmd}}($conn, $cmd, $rest);
- }
-diff --git a/tests/Makefile.am b/tests/Makefile.am
-index 5d387aa..daf162f 100644
---- a/tests/Makefile.am
-+++ b/tests/Makefile.am
-@@ -127,7 +127,8 @@ PX_TESTS = \
- Test--start-pos.px \
- Test--start-pos--continue.px \
- Test--httpsonly-r.px \
-- Test-204.px
-+ Test-204.px \
-+ Test-ftp-pasv-not-supported.px
-
- EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
- WgetTests.pm WgetFeature.pm WgetFeature.cfg $(PX_TESTS) \
-diff --git a/tests/Test-ftp-pasv-not-supported.px b/tests/Test-ftp-pasv-not-supported.px
-new file mode 100755
-index 0000000..97d0610
---- /dev/null
-+++ b/tests/Test-ftp-pasv-not-supported.px
-@@ -0,0 +1,60 @@
-+#!/usr/bin/env perl
-+
-+use strict;
-+use warnings;
-+
-+use FTPTest;
-+
-+# This test checks whether Wget *does not* fall back from passive mode to
-+# active mode using a PORT command. Wget <= 1.16.3 made a fallback exposing
-+# the client's real IP address to the remote FTP server.
-+#
-+# This behavior circumvents expected privacy when using a proxy / proxy network (e.g. Tor).
-+#
-+# Wget >= 1.16.4 does it right. This test checks it.
-+
-+###############################################################################
-+
-+# From bug report 10.08.2015 from tomtidaly@sigaint.org
-+my $afile = <<EOF;
-+FTP PORT command code in v1.16.3?
-+
-+In the past it could be possible for a site over http connection to
-+redirect wget to FPT using FTP PORT command so the site gets the real IP
-+of the computer even when wget proxy command is in use I believe:
-+https://lists.torproject.org/pipermail/tor-talk/2012-April/024040.html
-+
-+Is that code still present in wget v1.16.3? It was present in v1.13.4.
-+EOF
-+
-+$afile =~ s/\n/\r\n/g;
-+
-+
-+# code, msg, headers, content
-+my %urls = (
-+ '/afile.txt' => {
-+ content => $afile,
-+ },
-+);
-+
-+my $cmdline = $WgetTest::WGETPATH . " -S ftp://localhost:{{port}}/afile.txt";
-+
-+my $expected_error_code = 8;
-+
-+my %expected_downloaded_files = (
-+ 'afile.txt' => {
-+ content => $afile,
-+ },
-+);
-+
-+###############################################################################
-+
-+my $the_test = FTPTest->new (
-+ server_behavior => {pasv_not_supported => 1},
-+ input => \%urls,
-+ cmdline => $cmdline,
-+ errcode => $expected_error_code,
-+ output => \%expected_downloaded_files);
-+exit !$the_test->run();
-+
-+# vim: et ts=4 sw=4
--
2.5.1