summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2022-04-04 14:24:10 +0300
committerSergey Popov <pinkbyte@gentoo.org>2022-04-04 14:24:49 +0300
commit2a9a551f339e89c3da0c558ce94325fd962c130f (patch)
tree3401cfcce5bf0586b7e9bb63bf50fca23f8acee8 /net-misc/yandex-disk
parentnet-libs/rtrlib: version bump (diff)
downloadgentoo-2a9a551f339e89c3da0c558ce94325fd962c130f.tar.gz
gentoo-2a9a551f339e89c3da0c558ce94325fd962c130f.tar.bz2
gentoo-2a9a551f339e89c3da0c558ce94325fd962c130f.zip
net-misc/yandex-disk: version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-misc/yandex-disk')
-rw-r--r--net-misc/yandex-disk/Manifest2
-rw-r--r--net-misc/yandex-disk/yandex-disk-0.1.6.1074_p1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/yandex-disk/Manifest b/net-misc/yandex-disk/Manifest
index 15a4c7579773..6c6d5524e710 100644
--- a/net-misc/yandex-disk/Manifest
+++ b/net-misc/yandex-disk/Manifest
@@ -1,2 +1,4 @@
DIST yandex-disk-0.1.5.1039-1.fedora.i386.rpm 4556176 BLAKE2B 5ade043c21a13e678ca11b3074fb1392b99f461ef5a7bd7205b3d6ea984b20dec0ba086adb8b881eaf52888f04cf371dd63ce73432c3f82f31c895e03f31f073 SHA512 3c323e6aaa5fa669ef7efa80e4b899cd732a6b29235d81f635dce67d0ff59dafd01da8d9ea7b040242882f0e5e153f7cd623f4b993dfc390bc0a18d2811c1719
DIST yandex-disk-0.1.5.1039-1.fedora.x86_64.rpm 4743384 BLAKE2B 626a7e921567640b88d33fd426cc230bb92846a252b0960c51da9367f300b8622104db14c8788749e0f5cb484dffd9c9407994568449be769c24d2730cd0936a SHA512 9128d59f426de44b8c953d61ad07ffe886b5e864c5f20ba7ab1a69a47ab3269e5d4e39f4b92675f0ccaea43db1711184892a5e3178694bc453bc96e932045fa9
+DIST yandex-disk-0.1.6.1074-1.fedora.i386.rpm 4613237 BLAKE2B fa6c1643f11efb2cbbcda81cbc95c867abccf997f75352dbfcc93349e29694a0aa7c2d778847d77a6572fb4253dbb650564c5d744b3d9ea4320519d7bfc54ee5 SHA512 afb9d1e4896cecbedd005c6383bc44cc67e8b0df95dc1866e8d7540e3f9e73ad0584db93f987eb108c383f9ec6790d5cf80f804634f4d776b4b3459eb80c0bad
+DIST yandex-disk-0.1.6.1074-1.fedora.x86_64.rpm 4799146 BLAKE2B e51c7f39aa9fad7ad3316629b36e917d9555290168e3e58706c6f5b88ac4443286ebf741ae5aed36f39fd433710d2010eeba53199837598ee2821afec23c2cb5 SHA512 dab523455c6355ccb0b72019c9b8ea4c3e7f07e55081ae614866ad21927eef7026b3348eb46ede30dfe492ec37c11450484bee65cce829ab972badbb54c0d4cc
diff --git a/net-misc/yandex-disk/yandex-disk-0.1.6.1074_p1.ebuild b/net-misc/yandex-disk/yandex-disk-0.1.6.1074_p1.ebuild
new file mode 100644
index 000000000000..b8c324f9da4e
--- /dev/null
+++ b/net-misc/yandex-disk/yandex-disk-0.1.6.1074_p1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 rpm
+
+MY_P="${PN}-${PV/_p/-}"
+
+DESCRIPTION="CLI to access Yandex Disk file storage service"
+HOMEPAGE="https://disk.yandex.ru"
+SRC_URI="
+ amd64? ( https://repo.yandex.ru/yandex-disk/rpm/stable/x86_64/${MY_P}.fedora.x86_64.rpm )
+ x86? ( https://repo.yandex.ru/yandex-disk/rpm/stable/i386/${MY_P}.fedora.i386.rpm )
+"
+
+LICENSE="YDSLA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+DEPEND="app-arch/gzip"
+RDEPEND="sys-libs/zlib"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/bin/yandex-disk"
+
+src_prepare() {
+ # bug #526312
+ sed -i \
+ -e '/have /d' \
+ -e 's/+o nospace/-o nospace/' \
+ -e '/^complete/s/-X //' \
+ etc/bash_completion.d/yandex-disk-completion.bash || die
+
+ # Uncompress man pages to prevent QA warnings, bug #731684
+ find usr/share/man -type f -name *.gz | xargs gunzip
+
+ eapply_user
+}
+
+src_install() {
+ exeinto /opt/bin
+ doexe usr/bin/yandex-disk
+ newbashcomp etc/bash_completion.d/yandex-disk-completion.bash "${PN}"
+ insinto /usr/share/man
+ doins -r usr/share/man/*
+ insinto /usr/share
+ doins -r usr/share/locale
+}