summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-07-29 21:25:48 +0200
committerJeroen Roovers <jer@gentoo.org>2018-07-29 21:26:15 +0200
commit01200cf7dc458cbceae343c877c4e670bf9e2d93 (patch)
tree9aacaf447dc88ad85297cb4aae846a0758b54166 /net-misc/youtube-dl
parentnet-misc/youtube-dl: Install vendor_completions.d/youtube-dl.fish. (diff)
downloadgentoo-01200cf7dc458cbceae343c877c4e670bf9e2d93.tar.gz
gentoo-01200cf7dc458cbceae343c877c4e670bf9e2d93.tar.bz2
gentoo-01200cf7dc458cbceae343c877c4e670bf9e2d93.zip
net-misc/youtube-dl: Update live ebuild.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/youtube-dl-99999999.ebuild52
1 files changed, 39 insertions, 13 deletions
diff --git a/net-misc/youtube-dl/youtube-dl-99999999.ebuild b/net-misc/youtube-dl/youtube-dl-99999999.ebuild
index 683bc08f1a19..5d18c5096250 100644
--- a/net-misc/youtube-dl/youtube-dl-99999999.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-99999999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-inherit bash-completion-r1 distutils-r1 git-r3
+inherit bash-completion-r1 distutils-r1 git-r3 readme.gentoo-r1
DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://rg3.github.com/youtube-dl/"
@@ -13,34 +12,32 @@ EGIT_REPO_URI="https://github.com/rg3/youtube-dl.git"
LICENSE="public-domain"
SLOT="0"
KEYWORDS=""
-IUSE="offensive test"
+IUSE="+offensive test"
RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
- dev-python/sphinx[${PYTHON_USEDEP}]
test? ( dev-python/nose[coverage(+)] )
"
python_prepare_all() {
if ! use offensive; then
- sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
youtube_dl/version.py || die
# these have single line import statements
local xxx=(
alphaporno anysex behindkink camwithher chaturbate eporner
- eroprofile extremetube fourtube foxgay goshgay hellporno
- hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
- myvidster porn91 porncom pornflip pornhd pornotube pornovoisines
- pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
- tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
- youjizz youporn
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
+ pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
+ slutload spankbang spankwire sunporno thisav vporn watchindianporn
+ xbef xnxx xtube xvideos xxxymovies youjizz youporn
)
# these have multi-line import statements
local mxxx=(
- drtuber pornhub redtube tnaflix xhamster
+ drtuber fourtube motherless pornhub redtube tnaflix tube8 xhamster
)
# do single line imports
sed -i \
@@ -73,6 +70,8 @@ python_prepare_all() {
src_compile() {
distutils-r1_src_compile
+
+ emake ${PN}.{bash-completion,fish,zsh}
}
python_test() {
@@ -82,7 +81,34 @@ python_test() {
python_install_all() {
dodoc README.md
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/completions/vendor_completions.d
+ doins ${PN}.fish
+
distutils-r1_python_install_all
rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
}