summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-02-17 20:20:40 +0100
committerJeroen Roovers <jer@gentoo.org>2019-02-17 20:21:38 +0100
commit0b4fec5403f01e7c173ba2ebf2423131c4c7e05b (patch)
tree83d08afe01e2ebc120f2c9f79766e589c8aa0d26 /net-misc/youtube-dl
parentnet-irc/irssi: Do not apply libressl patch (diff)
downloadgentoo-0b4fec5403f01e7c173ba2ebf2423131c4c7e05b.tar.gz
gentoo-0b4fec5403f01e7c173ba2ebf2423131c4c7e05b.tar.bz2
gentoo-0b4fec5403f01e7c173ba2ebf2423131c4c7e05b.zip
net-misc/youtube-dl: Version 2019.02.18
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.02.18.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index be7dc0181fa4..8aa1dda4dcc2 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1 +1,2 @@
DIST youtube-dl-2019.02.08.tar.gz 3104780 BLAKE2B e89a9950de84c3d2c5530ca229f2dfb39bb372454a6a1d67c0d1c966f68f2372008556ffda32c042eca6d3c0aee3ace0c1cabdf1d65cb16efc80326b821a3624 SHA512 4fc027ec6d9d7059c34a3c16f1265989ec000c131e6a937f667928531dd2a6d9f56592d367f08ec5e3b1900b3e191aa36bcc997db04b77b95850a43ed1272640
+DIST youtube-dl-2019.02.18.tar.gz 3114830 BLAKE2B f948fc68d9bc2b7e400d22b4d2980b7f56bf734476a54b3e30b6ee33d5e4a0950233dfd74b0db26108a5759e3589acde4fe104d41ea856c88f68e165f330132b SHA512 86a321003b9e0bdc852294c8ac75d601141177f3469330c6ab01fa821758ee848dfcdf0e9dd514ca2da7b7e3c2a7f2dcddab9929f7fa8be2ab3c86d6eccbd5e3
diff --git a/net-misc/youtube-dl/youtube-dl-2019.02.18.ebuild b/net-misc/youtube-dl/youtube-dl-2019.02.18.ebuild
new file mode 100644
index 000000000000..2cb0551f3e35
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.02.18.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}