summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-10-22 16:06:05 +0200
committerJeroen Roovers <jer@gentoo.org>2017-10-22 16:06:19 +0200
commit14314713fec42eeef2551b10f1b9158fd6840031 (patch)
tree6b84c6df89aa71abb843cf915daa50e7d4f42826 /net-misc/youtube-dl
parentsys-fs/zfs-kmod: Fix max kernel version for -9999 #632640 (diff)
downloadgentoo-14314713fec42eeef2551b10f1b9158fd6840031.tar.gz
gentoo-14314713fec42eeef2551b10f1b9158fd6840031.tar.bz2
gentoo-14314713fec42eeef2551b10f1b9158fd6840031.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.10.20.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 10e59235ee2e..5104efe36cc9 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.10.07.tar.gz 2816312 SHA256 d9a8935087c1e2fa3307594ae15f1e9ea0f8676e825fa676a50a3a3d471bba83 SHA512 4842c8b324a10a4eff398226749ff8394ca60cf1e47873c1dfb5cf9828b77772670ea30891f32b26bab421aa0e7ca95e2815e062061a2cbaf22e6c5f76e1d87d WHIRLPOOL 525eb2eb3f18bf5ed1776f1a4d43dd010793b3b1681f27b3ed4ed4afdbd0c3dcd2c18b8e532de1fa3c318ac6a5f186c0bdf60fa4c7c69fe939335a7235679c3c
DIST youtube-dl-2017.10.15.1.tar.gz 2820437 SHA256 da6ae68b2fbe81da7cf4ac6b989fa7bf27b3beb214eed551d466cc6e41d7297f SHA512 6093747f732dac4eda4c71d334ed01fc24ba70d29e5660c38ff795861f06c4029441c3a4576e6a5463974488aeb7732687e5634481c8b04127f77499a2405a1c WHIRLPOOL cc8fca27f2a110fde556e6c6506a88715d4e4a03c971b7e74e77a91a5b28916c66146afd6e476a19aca2fff3270719da102d254a05f62dbabb5dc2a10040d839
+DIST youtube-dl-2017.10.20.tar.gz 2824647 SHA256 3e920a573218328a0864ffda5084093ec03108a7d4cd13cea7be85d7c342f95a SHA512 973465ad7d04f9d790fb9d36ca1c2c89c13f64b599ac3ef61f7720cd9d618d01619f76b419044eb716123e8300c1e2b4d881972a8240e0421f396dddd7affef1 WHIRLPOOL 2292bb5bdde62bc94b83d01da7b9a251fa88feaf95d2df703b40db36297cee75e76e776db4e0ca2959873f30655ee93cc52c76731230957a3bbbff0e5e736b0a
diff --git a/net-misc/youtube-dl/youtube-dl-2017.10.20.ebuild b/net-misc/youtube-dl/youtube-dl-2017.10.20.ebuild
new file mode 100644
index 000000000000..975ce26c347e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.10.20.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex motherless myvidster
+ porn91 porncom pornflip pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber fourtube pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}