summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-21 05:28:11 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-21 05:28:11 +0200
commit2e527f166220ef32055a03ee875cbe7ec7ab5422 (patch)
tree4a3952f5367752a81cb76db2bb8331006b296bf2 /net-misc/youtube-dl
parentwww-client/opera-beta: Old. (diff)
downloadgentoo-2e527f166220ef32055a03ee875cbe7ec7ab5422.tar.gz
gentoo-2e527f166220ef32055a03ee875cbe7ec7ab5422.tar.bz2
gentoo-2e527f166220ef32055a03ee875cbe7ec7ab5422.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.10.21.1.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 145990d80424..6a5e42b03cdb 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b
DIST youtube-dl-2016.09.19.tar.gz 2395739 SHA256 276637e83525778a83d0457f6b9fbc29d6109bc8366d43125432ce835d28545e SHA512 a8fb1ce054e25180eab3969c898d976dec157901931b66cddde0fecd55ef322e64c13a70d50de945849cbc4ccbf8be0aede845cbb8ea390bba34f51fec0533bf WHIRLPOOL e58d38e49d58b86d8eb25b40427046955e011bf57b0862c433ebe459c0268905bff67188c03bb612593d15b3d1f3408a95b510ad6f863d0144ee4307ed012aba
DIST youtube-dl-2016.10.16.tar.gz 2435016 SHA256 0ff39cbc17b4a73957238ab94ff5f05de2b7d833b0af3e2caf1df51eeeeacc60 SHA512 ee69ccc8ccfb77cc686d71fc90bc970b54417a6ec1492c16b5c2c42f0d8a4e740075cdfcf7fe4d4c2addd5bfd0ac14d73b02613dd01f7c3c9dca6dd1d4e127ab WHIRLPOOL 5183f16d760320937027bbd38c14561e90fb7be805982303575ab72b24a00a2c4bfec257538198eddd4b05d2f9c6dc796643bde2c323634a17d1d63d50ef9fbf
DIST youtube-dl-2016.10.19.tar.gz 2437154 SHA256 ed8d4a247c4cfffe2a1171b4f9c20be19e84d96bcf3716f46988c8503b1b7713 SHA512 71858676a333bce651f9166a1003afcedad54952cba792d64bb9797d84dd9dd6eeb5a68dfbdca143934f2ff629f19fb3886f45dcd8c52c167c011b340dfcf4e9 WHIRLPOOL 1008d11f89baa15301195f10cdd260df806cce0a26ca2213036bc3d7f023ad2c0997afa1315fa2200f27d4bc32f23698ad6c2cfe32c78210b8d3eb129e49a7bd
+DIST youtube-dl-2016.10.21.1.tar.gz 2439260 SHA256 8b768ad99ecdbc08521171456800515df29df8bceb0f1fe1cb8113dd2500d216 SHA512 76c1aab6acaaba2dee298c5fc1c9f7aee5cd497fc67db3c231c938e4a2ea1d01c835a9c3337d4f2620ea80cc3152f910123b895244c2144ca575fb2750382b1a WHIRLPOOL 957af290569bd63af70c83174514ed939bb8a6eb983e07f4a6f17b00381bcf044718d8e2a534eaa01f1b86af8f65fa9e6f691ac15262ded06e2ef588e0449dbe
diff --git a/net-misc/youtube-dl/youtube-dl-2016.10.21.1.ebuild b/net-misc/youtube-dl/youtube-dl-2016.10.21.1.ebuild
new file mode 100644
index 000000000000..1f0ca43a4f19
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.10.21.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}