summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-02 13:26:23 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-02 13:32:37 +0200
commit31477eba9c4629521ed0486ece069c2fedbfb607 (patch)
tree9f09bb3eeac6002d5a3313fb4a4f1153e7d7354d /net-misc/youtube-dl
parentx11-libs/wxGTK: Allow for compiling with GCC 6 (diff)
downloadgentoo-31477eba9c4629521ed0486ece069c2fedbfb607.tar.gz
gentoo-31477eba9c4629521ed0486ece069c2fedbfb607.tar.bz2
gentoo-31477eba9c4629521ed0486ece069c2fedbfb607.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.1
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.10.02.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index ab674ae73f1f..827e16f3bc41 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b
DIST youtube-dl-2016.09.19.tar.gz 2395739 SHA256 276637e83525778a83d0457f6b9fbc29d6109bc8366d43125432ce835d28545e SHA512 a8fb1ce054e25180eab3969c898d976dec157901931b66cddde0fecd55ef322e64c13a70d50de945849cbc4ccbf8be0aede845cbb8ea390bba34f51fec0533bf WHIRLPOOL e58d38e49d58b86d8eb25b40427046955e011bf57b0862c433ebe459c0268905bff67188c03bb612593d15b3d1f3408a95b510ad6f863d0144ee4307ed012aba
DIST youtube-dl-2016.09.24.tar.gz 2412049 SHA256 d45a17fb6be7d2e6c3df56f54d1a944fac8b68a577b673d8b15cef8e47bb3a57 SHA512 c326cf00d810ccf7abe7b8726152681408202a55832f34c02bde492e8dfe2d2f4aaa25b913c934e08b769d9943cfe6944a94cdb836b3dce338aeaf516ce90453 WHIRLPOOL 57d83dd142d9d996df2768ef487ce00eda269711ab19e0281ab1f6d41da8dce358a043d730f7e7bf12bebf002953ae5308494929cd79b534a7bc247ed12e0dc4
DIST youtube-dl-2016.09.27.tar.gz 2417032 SHA256 dfae0d25cb515d17e7145b7ab0edf0c85f77ef4975aefe46719fdef0a5d4a879 SHA512 cf4cb7b589ace3bc544616078f1495be4460779298bbe230743319e3a25dc06cc885381e37fa6905e8e3139f54db44ce1f33d5a2993d92b8caa7ebad147e4fc8 WHIRLPOOL b0b375af9087d13488951ebaec9da63782dd03713fe800e08116a65ef292b6ed60b7ffe5e3d988f16fdc427823074b80979d58ea1b0cf91de5cf8ffe2677f225
+DIST youtube-dl-2016.10.02.tar.gz 2417904 SHA256 ecc58e3661c70ed3eeb46712461ad53f92d0b815d4030466d6a29eca9f6869ba SHA512 23d964de978eb313173f9d602bde580550a53fe09007854d2da943988b8bdabcc6ba5856303083c86f2af618e63ec2d41b6e6c68cc230c522fe4ccb7ad899257 WHIRLPOOL b5c53dfec5bcbeb97969ea66f74d6d70afeed3c1d8b2cf080d387d41586a4b5118c27bade32f227583f56e4986f76c46359ba19c8a6909284cdb62d6d0ef4a4c
diff --git a/net-misc/youtube-dl/youtube-dl-2016.10.02.ebuild b/net-misc/youtube-dl/youtube-dl-2016.10.02.ebuild
new file mode 100644
index 000000000000..233bdf46fe97
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.10.02.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${D}"/usr/etc || die
+}