summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-05-21 23:52:16 +0200
committerJeroen Roovers <jer@gentoo.org>2017-05-22 00:33:58 +0200
commit362983bb638297af08cb727f1995c088dca213d8 (patch)
tree73c15c69eabdc71e50cbb6436c93809125712fe4 /net-misc/youtube-dl
parentdev-python/hcs-utils: version bump. (diff)
downloadgentoo-362983bb638297af08cb727f1995c088dca213d8.tar.gz
gentoo-362983bb638297af08cb727f1995c088dca213d8.tar.bz2
gentoo-362983bb638297af08cb727f1995c088dca213d8.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.05.18.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index a7e78183a516..c8199ebd909d 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.05.07.tar.gz 2714748 SHA256 45308c76b5e49b657ec7fa23b6b09e4d832355b54c86da79f09586b9664f6be0 SHA512 38a22c83a7f2d101a4afbee80d0c859dd37ad488b9e9bc22fb1043d8cae63ec063eaf880eafd066571e5d60e4778420b6113074cc55b323b0259657d5f5e8e54 WHIRLPOOL 5cc328da1181d8514d5dbdb126eb64d316b265baab7b2dee7eaa54383d4f4cc5fee1b57e84dcdc7933e6c98c03aafea9f46f4e35e4a5eaa018f66ba5eee20353
DIST youtube-dl-2017.05.09.tar.gz 2711823 SHA256 b9af1b8f5b8b245fe46348e7743cf01d323f927e32bd7a98dfdfc83b2866df15 SHA512 459604b6398782be9d6315bb434dff5c19fdc0069249389a1c7c32fa42d9e5300ff60f3d824bb7f9af74ecd0421817601a923d3c53aa7e802bee6c84a1c7e41f WHIRLPOOL 23092b3280d6d1414309603caf407893af7b2c70b47a8233737519b88a82a6cd5ca279e5d2798daea781796d32c4efcac3bd3ca3c75af419cca4659a083c0957
+DIST youtube-dl-2017.05.18.1.tar.gz 2721977 SHA256 549f0ff6400bf0db966f4f2bec7fcf102ae9aff2e044c649c1dcdbd90f6fa299 SHA512 a2f6919e8ba2c80a5a358c6ef53a8eaa8916b5d68f99de61aa1639887f87209a5db1549177fd59289c5783de658c7cf02a5738b4b09abc5a7bca2d8f48d562b1 WHIRLPOOL 115dcc69ce560c8f40ff2ac26c743a558d2f88a72d43fff6da7f1fd28468f31da0960068a0c065380b6d27141746beb5d1346f093842dc967c64e47c13b53914
diff --git a/net-misc/youtube-dl/youtube-dl-2017.05.18.1.ebuild b/net-misc/youtube-dl/youtube-dl-2017.05.18.1.ebuild
new file mode 100644
index 000000000000..867867e73614
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.05.18.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornflip pornhd pornotube pornovoisines
+ pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}