summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-30 22:51:46 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-30 22:56:19 +0100
commit600ac5b121fd993d92d5daf5c9c04219af28175d (patch)
tree1614b87da5e06e8c800a099cbf4f0f4301e15f89 /net-misc/youtube-dl
parentwww-client/opera-developer: Old. (diff)
downloadgentoo-600ac5b121fd993d92d5daf5c9c04219af28175d.tar.gz
gentoo-600ac5b121fd993d92d5daf5c9c04219af28175d.tar.bz2
gentoo-600ac5b121fd993d92d5daf5c9c04219af28175d.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.12.01.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index dbdec4e06250..e5151e5e416d 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b
DIST youtube-dl-2016.09.19.tar.gz 2395739 SHA256 276637e83525778a83d0457f6b9fbc29d6109bc8366d43125432ce835d28545e SHA512 a8fb1ce054e25180eab3969c898d976dec157901931b66cddde0fecd55ef322e64c13a70d50de945849cbc4ccbf8be0aede845cbb8ea390bba34f51fec0533bf WHIRLPOOL e58d38e49d58b86d8eb25b40427046955e011bf57b0862c433ebe459c0268905bff67188c03bb612593d15b3d1f3408a95b510ad6f863d0144ee4307ed012aba
DIST youtube-dl-2016.11.18.tar.gz 2471267 SHA256 8e4bb3ef4f90ed03c822ff0bffce54d298cdf135d57bf4ff1605fc85157c0d3a SHA512 218b59c0bde9e371690fa03b0812fc2021a1be57a4c6d3022873553c496a969406a1fd5e13c7b65b4ddbeddbe2a24cb3d34fd523c3f1f868f267cc17c9303afe WHIRLPOOL 9ffd5e529f8c2568d3d370dac0064058236d440ecfa6a6b676ef2c5e0355e1539c2193d86467d8b8f5d983c6dcb6769adc334ec8abfb6a3bce1614b5920df261
DIST youtube-dl-2016.11.27.tar.gz 2478620 SHA256 6ecc3996e28b6274d159643641a964098549b4cb8b33a3a3481148b88166e2cc SHA512 900dbbb76de1c897c7f0d2623fd62be39a26467b208b486a5b466e3f2b96a971d9e741189b03e2aca56adfc715e23462a1e6dcd8f55342469f7782d4818cab4b WHIRLPOOL 3988d9c13ea65f814bea3f8890aba96a2baf9d2fe959c27dccb1f2eb0da052d3899b2552f709aa7e425eb46ced6711d257098d6d04a2e6941522646ca20f26c0
+DIST youtube-dl-2016.12.01.tar.gz 2478435 SHA256 ddff281a251c7a40bf8c28afa1df63e9a64ff61b6b8097535fbbe587e8ccaef7 SHA512 3e2cef363d2186bcb3e818848cae4a0d6455748f6c4b7f35e56e41a65c00e4d49726d53d06d59b9decb91eb60950087143e380c860cd605b72278cef830f2229 WHIRLPOOL a28315ba64f4417b4b77a5558a6ce55347e3d6a4afe3674ff176953f1527d41dc3e1cc03dc6854f4f0294acff809fb8382de91d735517d8bfbea029683f5ea97
diff --git a/net-misc/youtube-dl/youtube-dl-2016.12.01.ebuild b/net-misc/youtube-dl/youtube-dl-2016.12.01.ebuild
new file mode 100644
index 000000000000..1470648bf54c
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.12.01.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}