summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-09-26 11:42:58 +0200
committerJeroen Roovers <jer@gentoo.org>2018-09-26 11:54:01 +0200
commit761e20d419526eff064e9f349dc82aa0049a9c7e (patch)
treeaf64b36c52206caaa91142867654b5983d6799a0 /net-misc/youtube-dl
parentdev-tcltk/tcl3d: Fix missing RDEPEND and modularize (diff)
downloadgentoo-761e20d419526eff064e9f349dc82aa0049a9c7e.tar.gz
gentoo-761e20d419526eff064e9f349dc82aa0049a9c7e.tar.bz2
gentoo-761e20d419526eff064e9f349dc82aa0049a9c7e.zip
net-misc/youtube-dl: Version 2018.09.26.
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2018.09.26.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 54d14c6705d9..857d9a9778cb 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2017.11.15.tar.gz 2834012 BLAKE2B fd93e3923f99874be58681a886c09e
DIST youtube-dl-2018.08.22.tar.gz 3025389 BLAKE2B e8d2d8bccab8c169d08de35544e5efb05c65799c26894807e075edfe090d36de30fea787f54d59e4fc8b671356ce2e1d9002627948fb05becc9d2e3bc634164c SHA512 ef17c744ac27b3bf547124f18a155908a66ee75f3f6fb5d7dd8a1d8da61a5a598bbade6cf0362e8c93c337dcf47750db5f56357919226430f02d0b764011ffb5
DIST youtube-dl-2018.09.10.tar.gz 3036301 BLAKE2B 341e74da88ccb890cf41ce81b3f541118b6afcae6baa6bc7722e41730894ee466e57b3475622309de12dec01e15d51534db90fe5751f785287665416e3ba71de SHA512 ebc0b0357231173718be3b94c2c2974496170e039a69cb58d809a1973a56306af058d91f485d2bacee5d665fea1f96d9f7243960556b42a7280a647611dca750
DIST youtube-dl-2018.09.18.tar.gz 3041086 BLAKE2B 6cca8e87c26f9b2d1c9aa117d4e798cd80b12a423a9f63f2d79a6b55d21f497f372a1d5d72f48ebdf52d658f26934c7f1db9e44b5b6ed030bcb55a452a3e8f44 SHA512 9ec58e05fb7db0e08ffeea3810631b21654dda9a57849db76a7a8f9dfb6fc95fd685b36188354c9b28f6e35c818a56c44e4c55bc826d2d1c19b96cecfcc8662e
+DIST youtube-dl-2018.09.26.tar.gz 3042551 BLAKE2B 1cf4fe51a55bd82bacf5405119f91c78d975d755c8dc50e41b52f8e0af26074d6873b4046970afda81b3732825918c3bd1a14aaf3ef554096db063b365a72e6a SHA512 b54721bd9b6c6bb66d0ddf4000a435bf8f4d3884a513aada844497db38a5bca34f82484b483b20adb709043ffdd1c00b6aa6cb9c5e6d5be2306d0ae7be77caee
diff --git a/net-misc/youtube-dl/youtube-dl-2018.09.26.ebuild b/net-misc/youtube-dl/youtube-dl-2018.09.26.ebuild
new file mode 100644
index 000000000000..8a6b3e14fd72
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2018.09.26.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
+ pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
+ slutload spankbang spankwire sunporno thisav vporn watchindianporn
+ xbef xnxx xtube xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber fourtube motherless pornhub redtube tnaflix tube8 xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+}