summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-08-27 16:35:30 +0200
committerJeroen Roovers <jer@gentoo.org>2017-08-27 16:36:13 +0200
commit90e62ab6fb2e7d78c82e7795af0a212547238216 (patch)
treee31c0e21d3cf7250904037b186a23cff6e288f4e /net-misc/youtube-dl
parentdev-python/futures: stable 3.1.1 for ppc/ppc64, bug #629034 (diff)
downloadgentoo-90e62ab6fb2e7d78c82e7795af0a212547238216.tar.gz
gentoo-90e62ab6fb2e7d78c82e7795af0a212547238216.tar.bz2
gentoo-90e62ab6fb2e7d78c82e7795af0a212547238216.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.08.27.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 61b07ffdd333..ba10e07f4613 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.08.18.tar.gz 2779312 SHA256 a7f4279b7b8b54f44025fccc22f3e511cae77314f7d37b73334c981946e4c3d6 SHA512 bf403e2f4b7024346219ce01b229ab18329e3faf7aadbd0706e7783072815eaf588812ccbed876212d57192533c09ec8aaceb4a497a411672533b436a9f215f5 WHIRLPOOL a262d999ef27f44b4daeda207b35d2f4952aa04f5b965ada8d47a9b2f64d0f887a5d2276a13db297e9d40957c266556db551ed326beddd5239951cd0262dfc12
DIST youtube-dl-2017.08.23.tar.gz 2783237 SHA256 90c56ce90cd99cefb83607c37b0b641c7e4e1ef37040ad4187425aebcfc800ef SHA512 d4e1407558ed7dc7369ada2eabbd64f0e74b718abc67f7f4aa1eef8f522880a63b943b70b6af4b18df176db72c9e9552f1e36727312944b62b6d3aae3bc11b4e WHIRLPOOL 32620396ae7e7b620e956539a5afd98223dff176ad6306fc291bc4f4bdace5a309b9b5f7afc1ee5c982d5e62c7d93886073d3c5c29629673f0336c8378216fba
+DIST youtube-dl-2017.08.27.1.tar.gz 2784682 SHA256 32d823b8aa1714c40e20f920e481be48d7458d657e66d118a0467a351d680aac SHA512 4cbe2c2b917b59ccb5a171a171c69d5bdd915a56a4ca2d4bf67a04c7425b2d4849403a78d954cd0aa8401f8f4b61e4ebe96160aba2a9d2f3da1eae026739e9ba WHIRLPOOL c99cde85126741845a1e45873f8d79362775b4066a9736b563d15993d88c5b9201c9cb2239b8db85a8e18a91f7118906bd0ad5cd93e98a8538d7f796df0fb675
diff --git a/net-misc/youtube-dl/youtube-dl-2017.08.27.1.ebuild b/net-misc/youtube-dl/youtube-dl-2017.08.27.1.ebuild
new file mode 100644
index 000000000000..fa2e8cbf808f
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.08.27.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies lovehomeporn mofosex motherless myvidster
+ porn91 porncom pornflip pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber fourtube pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ eapply_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}