summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-06-28 00:39:44 +0200
committerJeroen Roovers <jer@gentoo.org>2019-06-28 00:40:13 +0200
commita739f7388182a69a76288a5256fc13ee6b8d9e6e (patch)
treeaa4b1adf4f87b05a93bbfe2b405d002fa8af9b9d /net-misc/youtube-dl
parentdev-libs/libuv: Version 1.30.0 (diff)
downloadgentoo-a739f7388182a69a76288a5256fc13ee6b8d9e6e.tar.gz
gentoo-a739f7388182a69a76288a5256fc13ee6b8d9e6e.tar.bz2
gentoo-a739f7388182a69a76288a5256fc13ee6b8d9e6e.zip
net-misc/youtube-dl: Version 2019.06.27
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.06.27.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 2b48f7061764..f9b60aa9d042 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1 +1,2 @@
DIST youtube-dl-2019.06.21.tar.gz 3169975 BLAKE2B c8867638147e45f5f1137b89b0259301b717a2249ac96143f70dc3b0b6850f887cf402e8e5e22249afaef40409a2f1c4137051553f5750633f3dc79d42967b59 SHA512 b116f1b636b616e7bd2f5f3d8bbec3b9acebc956f2864391392cfa8bd2af91faa97603d528a13abb6e69ac861582d296870579469e4c6f4f4816dc674e0c27bb
+DIST youtube-dl-2019.06.27.tar.gz 3170966 BLAKE2B f105f246e0f3e7edac2ada6685475d0b35cb3bcba39e36dbccbddf58d5103c25d93c6fe0ec8cf3fb64d35d53ab12283450184a414f551b1937c4547f2b441c4e SHA512 f59f6633b5f516736403e48f21e29684447fd12424d94423b7acca6809e9531ecf2922eec528ba7e8d9b7c62d12201c3194fccce95121ef4fc5430a8f64d4e6c
diff --git a/net-misc/youtube-dl/youtube-dl-2019.06.27.ebuild b/net-misc/youtube-dl/youtube-dl-2019.06.27.ebuild
new file mode 100644
index 000000000000..a8b1afbfc11a
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.06.27.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}