summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-01 19:42:54 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-01 19:59:17 +0100
commite2e97dbcbacb25f50dc2f2dc20736c0305adf9ee (patch)
treeb9064ac55145f34b3e5f33f9fd1fbd366c58eff6 /net-misc/youtube-dl
parentx11-base/xorg-server: Drop old versions (diff)
downloadgentoo-e2e97dbcbacb25f50dc2f2dc20736c0305adf9ee.tar.gz
gentoo-e2e97dbcbacb25f50dc2f2dc20736c0305adf9ee.tar.bz2
gentoo-e2e97dbcbacb25f50dc2f2dc20736c0305adf9ee.zip
net-misc/youtube-dl: Bump to 2020.12.02
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2020.12.02.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 8de8a9401878..c6f6769e86a8 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2020.09.20.tar.gz 3188480 BLAKE2B c12ee589d112155207b59da9f710b2c776c07464d5c64a5d8355b963a81765b0dbc65df4f9564504fb963f30d5a11dc7e662c14d58ddf9fe6347352363cf70a5 SHA512 ed511016d0cfcbbee0cd651f793cb31cdb46d80243f86186de1cc54cb2a2055fae2f5cc3e16f838fc2ba47f3ff6f3b484219c8a707904fbc30193a2b28a1e30c
DIST youtube-dl-2020.11.26.tar.gz 3218922 BLAKE2B 4e8ac926a7cef9d8a9f53de1002464e4d3a632d09c6564e1451a7bc49fe4cdf72e206f98df58a4025d55718f46d84fe4f1f6e23268ef19ad3ebd11725d5a0fcc SHA512 126c299c3db654ad3c88ced44bfc1a34bd73a439d8d3fd64720bb5d06fe84df817182a9e0b38d1def2eb4f1de26c7e2b8b6d3d6b4282f973db548c9868938a41
DIST youtube-dl-2020.11.29.tar.gz 3222467 BLAKE2B 6b699689f55fb5b24d9a3fa9b500461076d9cac58a111fde5f07f4df45113d40cb2cfbec2b86777b92277fbe16467c1516fdd5bb49e30f8361dd7fe3479eca57 SHA512 e3b4e7e7a776a608d2ee34c5395108445ea43fc999b0364a686eddb5d5977591d2c625b2a97955fd565631da070921f3196cd98ce58cf9aebf4e504636645a3d
+DIST youtube-dl-2020.12.02.tar.gz 3225560 BLAKE2B 953de14c6801a853091625753c0f918e7c6f88b1631ed2d41427fc36cc615830161f860e043ca784b31b1845ecfd0f5a88afcaeca40dc797cd89d36d4762d637 SHA512 5e48e272d957be391cb18960e0b1864b0f2202e26a53491f5c15f6c40bc36e720d80e95955a5a2f889e05f11a999fd311d095b18e5082bb951739c63ffe7565a
diff --git a/net-misc/youtube-dl/youtube-dl-2020.12.02.ebuild b/net-misc/youtube-dl/youtube-dl-2020.12.02.ebuild
new file mode 100644
index 000000000000..47f8343b521a
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2020.12.02.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..9})
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. ${PN} will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}