summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2017-05-24 23:49:49 -0700
committerPatrice Clement <monsieurp@gentoo.org>2017-06-30 14:25:07 +0200
commitd255de756438544d0aeb12da260cc41483a4e5af (patch)
treeec5fcb7ee7664e2dc3c53fe16cacc49e6f575062 /net-misc/youtube-viewer/youtube-viewer-3.2.8.ebuild
parentapp-editors/atom: version bump to 1.18.0. (diff)
downloadgentoo-d255de756438544d0aeb12da260cc41483a4e5af.tar.gz
gentoo-d255de756438544d0aeb12da260cc41483a4e5af.tar.bz2
gentoo-d255de756438544d0aeb12da260cc41483a4e5af.zip
net-misc/youtube-viewer: version bump to 3.2.8.
Adjusted dependencies according to release, fixed RDEPEND of video players, allowed ffmpeg with gnutls Gentoo-Bug: https://bugs.gentoo.org/600460 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4989
Diffstat (limited to 'net-misc/youtube-viewer/youtube-viewer-3.2.8.ebuild')
-rw-r--r--net-misc/youtube-viewer/youtube-viewer-3.2.8.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/youtube-viewer/youtube-viewer-3.2.8.ebuild b/net-misc/youtube-viewer/youtube-viewer-3.2.8.ebuild
new file mode 100644
index 000000000000..3b5e362cd1be
--- /dev/null
+++ b/net-misc/youtube-viewer/youtube-viewer-3.2.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils perl-module
+
+DESCRIPTION="A command line utility for viewing youtube-videos in Mplayer"
+HOMEPAGE="https://trizenx.blogspot.com/2012/03/gtk-youtube-viewer.html"
+SRC_URI="https://github.com/trizen/youtube-viewer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-1+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="
+ dev-perl/Data-Dump
+ dev-perl/JSON
+ dev-perl/libwww-perl[ssl]
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/LWP-Protocol-https
+ virtual/perl-Encode
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Term-ReadLine
+ virtual/perl-Text-ParseWords
+ virtual/perl-Text-Tabs+Wrap
+ gtk? (
+ dev-perl/File-ShareDir
+ >=dev-perl/Gtk2-1.244.0
+ virtual/freedesktop-icon-theme
+ x11-libs/gdk-pixbuf:2[X,jpeg]
+ )
+ || ( media-video/ffmpeg[openssl] media-video/ffmpeg[gnutls] )
+ || ( media-video/mpv media-video/mplayer media-video/vlc gtk? ( media-video/smplayer ) )"
+DEPEND="dev-perl/Module-Build"
+
+src_configure() {
+ local myconf
+ if use gtk ; then
+ myconf="--gtk-youtube-viewer"
+ fi
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+
+ if use gtk ; then
+ domenu share/gtk-youtube-viewer.desktop
+ doicon share/icons/gtk-youtube-viewer.png
+ fi
+}
+
+pkg_postinst() {
+ use gtk && gnome2_icon_cache_update
+ elog "Optional dependencies:"
+ optfeature "cache support" dev-perl/LWP-UserAgent-Cached
+ optfeature "faster JSON to HASH conversion" dev-perl/JSON-XS
+ optfeature "the case if there are SSL problems" dev-perl/Mozilla-CA
+ optfeature "printing results in a fixed-width format (--fixed-width, -W)" dev-perl/Text-CharWidth
+ optfeature "threads support" virtual/perl-threads
+ elog
+ elog "Check the configuration file in ~/.config/youtube-viewer/"
+ elog "and configure your video player backend."
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}