summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-10 00:50:55 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-11-10 00:57:00 -0500
commit0997e05276e0c141673fda60e6a9c02653760d78 (patch)
treecbec72b092ebeb9f0a4831abb74b51480a1c8dba /net-misc/yt-dlp
parentx11-drivers/nvidia-drivers: drop 470.63.01 (diff)
downloadgentoo-0997e05276e0c141673fda60e6a9c02653760d78.tar.gz
gentoo-0997e05276e0c141673fda60e6a9c02653760d78.tar.bz2
gentoo-0997e05276e0c141673fda60e6a9c02653760d78.zip
net-misc/yt-dlp: add 2021.11.10.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2021.11.10.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index dfa7cc0b1694..615580448985 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2021.10.22.tar.gz 2010916 BLAKE2B fb8f789c74df06dcd672d00ac16eb7cbf466755c3fa607acdd21dd9a9ef2af158a5272f88656133078bd50585506b65cf3b3c03236726de954ccfa0b6c1195fc SHA512 2b590703f8d4f9454b50983019aca8046205234bd98cac4da73a6688eae177a19ef641e486aea92d86197ee7ad6c564c65f9b9496d623c00bdcc349817d5b1f8
+DIST yt-dlp-2021.11.10.1.tar.gz 2042241 BLAKE2B c4542edce26931a8753002a5cf0fda46549dd9b79709fc595c0c807837b07242d5d7a7fa19cc4f64cf7b7fc5803c4937185d68f4593250f9fa21155d5a24ee92 SHA512 54a371d70b7b82349a184b26201fca12fabbc9a107dc199347c412062776d63879d22955d76726df61bc40ec594a7179a997e4679c683673c8c0dd41f62b16f6
diff --git a/net-misc/yt-dlp/yt-dlp-2021.11.10.1.ebuild b/net-misc/yt-dlp/yt-dlp-2021.11.10.1.ebuild
new file mode 100644
index 000000000000..1aa701367fef
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2021.11.10.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 optfeature
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ newbin - youtube-dl <<-EOF
+ #!/usr/bin/env sh
+ exec yt-dlp --compat-options youtube-dl "\${@}"
+ EOF
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]] ||
+ ver_test ${REPLACING_VERSIONS} -lt 2021.10.22-r2; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}