summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-21 10:20:51 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-21 12:12:50 -0500
commit50fe651d475cbb4705dc3690249b570fe3873a2b (patch)
tree7f2effb87f4d2c5a611c181fba1525572f0c8fb0 /net-misc/ytfzf
parentmedia-gfx/ueberzug: initial import, 18.1.9 (diff)
downloadgentoo-50fe651d475cbb4705dc3690249b570fe3873a2b.tar.gz
gentoo-50fe651d475cbb4705dc3690249b570fe3873a2b.tar.bz2
gentoo-50fe651d475cbb4705dc3690249b570fe3873a2b.zip
net-misc/ytfzf: initial import, 1.2.0_p20211208
Using snapshot for yt-dlp support. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/metadata.xml15
-rw-r--r--net-misc/ytfzf/ytfzf-1.2.0_p20211208.ebuild44
3 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
new file mode 100644
index 000000000000..0bb9d14394f6
--- /dev/null
+++ b/net-misc/ytfzf/Manifest
@@ -0,0 +1 @@
+DIST ytfzf-1.2.0_p20211208.tar.gz 3230303 BLAKE2B eb1cc05945bc91226d9a3f893edfcfcc5d8544ac2607d6bec7bfc5dd4a8f4b0c01e7387a73d82d148e908e727a1f2809765c9e21e13ca9e7de947c68c1a28f10 SHA512 f87dea2afb706ec9ea23fab3fa02833ddeff7261807f8e2e77471829fe05d293644c6b1d75660cbaae798cfdaede5553d1eabcf6b608a08a7a9d2de825ab92a2
diff --git a/net-misc/ytfzf/metadata.xml b/net-misc/ytfzf/metadata.xml
new file mode 100644
index 000000000000..b6a91b9d9370
--- /dev/null
+++ b/net-misc/ytfzf/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <use>
+ <flag name="minimal">Skip <pkg>app-shells/fzf</pkg> and <pkg>media-video/mpv</pkg> dependencies (requires custom settings)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">pystardust/ytfzf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/ytfzf/ytfzf-1.2.0_p20211208.ebuild b/net-misc/ytfzf/ytfzf-1.2.0_p20211208.ebuild
new file mode 100644
index 000000000000..0ba10e67d3ae
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-1.2.0_p20211208.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+MY_COMMIT="dc7b0056e9b84cf786e6e4adda7f91564d1d012f"
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+# fzf/mpv "can" be optfeatures depending on configuration, but depend
+# on them so it works as expected out-of-the-box and allow to disable.
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ net-misc/yt-dlp
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ )"
+
+src_compile() { :; }
+
+src_install() {
+ dobin ytfzf
+
+ dodoc README.md docs/{USAGE.md,conf.sh}
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu x11-misc/rofi
+ optfeature "in-terminal thumbnails on X11" \
+ "media-gfx/ueberzug dev-python/pillow[jpeg]"
+ optfeature "desktop notifications" x11-libs/libnotify
+}