summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-06-17 19:04:45 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-09-19 16:36:21 +0300
commit1ed32a5e54cce24ce99cfb3e5a4995bd613c60e6 (patch)
treed5703b398864e4233a62078167e75cdc344b73ec /net-misc/zsync/zsync-0.6.2-r3.ebuild
parentsys-kernel/vanilla-sources: add 6.5.4 (diff)
downloadgentoo-1ed32a5e54cce24ce99cfb3e5a4995bd613c60e6.tar.gz
gentoo-1ed32a5e54cce24ce99cfb3e5a4995bd613c60e6.tar.bz2
gentoo-1ed32a5e54cce24ce99cfb3e5a4995bd613c60e6.zip
net-misc/zsync: Fix error: type specifier missing, defaults to int
Closes: https://bugs.gentoo.org/898062 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31520 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/zsync/zsync-0.6.2-r3.ebuild')
-rw-r--r--net-misc/zsync/zsync-0.6.2-r3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/zsync/zsync-0.6.2-r3.ebuild b/net-misc/zsync/zsync-0.6.2-r3.ebuild
new file mode 100644
index 000000000000..08e57393fa50
--- /dev/null
+++ b/net-misc/zsync/zsync-0.6.2-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+ZLIB_PV=1.2.3
+ZLIB_P="zlib-${ZLIB_PV}"
+
+DESCRIPTION="Partial/differential file download client over HTTP using the rsync algorithm"
+HOMEPAGE="http://zsync.moria.org.uk/"
+SRC_URI="
+ http://zsync.moria.org.uk/download/${P}.tar.bz2
+ http://www.gzip.org/zlib/${ZLIB_P}.tar.bz2
+ http://www.zlib.net/${ZLIB_P}.tar.bz2"
+ZLIB_S="${WORKDIR}/${ZLIB_P}"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.2-musl-off_t-fix.patch
+)
+
+src_prepare() {
+ default
+ # Move old zlib-1.2.11 out the way
+ mv "${S}"/zlib zlib-1.2.11-modified || die
+
+ cd "${ZLIB_S}" || die
+ # I am not sure how many other zlib patches we will need to port as well
+ # This covers the security vuln in 1.2.11
+ eapply "${FILESDIR}"/${P}-${ZLIB_P}-support.patch
+ rm Makefile || die
+
+ cd "${S}" || die
+ cp -a "${ZLIB_S}" "${ZLIB_P}-modified" || die
+ ln -s "${ZLIB_P}-modified" zlib || die
+
+ eautoreconf
+}
+
+src_install() {
+ dobin zsync zsyncmake
+ dodoc NEWS README
+ doman doc/zsync.1 doc/zsyncmake.1
+}