summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2018-01-18 22:08:00 +0300
committerMaxim Koltsov <maksbotan@gentoo.org>2018-01-18 22:09:05 +0300
commit02df5ee7ce3b816747598171bca108868e143815 (patch)
tree4b7e45788482077575aa1176053983f87535f34f /net-misc
parentnet-misc/radvd: arm stable, bug #637520 (diff)
downloadgentoo-02df5ee7ce3b816747598171bca108868e143815.tar.gz
gentoo-02df5ee7ce3b816747598171bca108868e143815.tar.bz2
gentoo-02df5ee7ce3b816747598171bca108868e143815.zip
net-misc/teamviewer: bump version to 13.0.6634
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/teamviewer/Manifest2
-rw-r--r--net-misc/teamviewer/teamviewer-13.0.6634.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
index b427b9618be1..7390d3fb3a9f 100644
--- a/net-misc/teamviewer/Manifest
+++ b/net-misc/teamviewer/Manifest
@@ -1,3 +1,5 @@
DIST teamviewer-9.0.32150.deb 22898922 BLAKE2B 799aa6f48b69247a2695ca745e85d02ffa73df1375203dfc9da339673e6c18d861c4146ddbdc509bdc1114d5a2a7e5fdd4acf3c6e5da61fbba5aaa02fa4e3cfd SHA512 3e72ed5cab7a754a0aa75e533da92292ad004f66c55ac4c386b6f4a65cc41b14a8d9d7a5410dccdb90c1172cd33e52383289339ab44f0847a061655498ab8e4d
DIST teamviewer_13.0.5693_amd64.tar.xz 9694952 BLAKE2B 650814c3c63897e1024836528c6eaa4cc81064ffa16bece7f8d2fe633457e2795e2cef847175a88dbb389ba61d2597a02292e6bf610da25c92f97152560ea355 SHA512 75886b6d00991968ae0b0d3c55b4c07c6f1b1b24488b2d5ae866e35c26ee6e673e500c87845ba6850ffdc80e4612feff0fc5bbe9e39f2d0a94582e1800471dcc
DIST teamviewer_13.0.5693_i386.tar.xz 9583892 BLAKE2B 8e477978825431a01b37b61c28b903b36cd81365c7ec5df4ca8d4aec1ce8d24b49af60ed6c99c863acd26405254ae78c4ae4dfef1f8b7a5fb882e281c3c4f125 SHA512 be5e8e00755a38f2c70ceba88d9fb87c2cc8e9e284c86e22f95dddf919a37ee1f24ef1e02f042a339eaf863dbf255c873e3edcb038c04202b4ab0460e50b2503
+DIST teamviewer_13.0.6634_amd64.tar.xz 9316708 BLAKE2B c48aed992de6b23728de155c09dca96258d1a124df34f904bad8ae1fc85777ce9b1606a75ae1d40e32f5e2f8b313f54013205d1711302d2fef8c55a4d0e450d8 SHA512 5f4f662ffc0499d3cbd8b6310999b34e14a324152dd9e75352879d8cf0e53058c035c9bad987af046aa6715d3b579ab3887f339e68db8ca71e11348b1703d78c
+DIST teamviewer_13.0.6634_i386.tar.xz 9258092 BLAKE2B 85a5e169486956cb226ea5cf2a2497ae4de88d3d94a961a819dce0a179fb0cf7959719b784def98d7c7e39151307bc0ec17a21d9d7f7e291c52715a9fbb815d8 SHA512 796ff9c9a39f769b9034875f5dc513a4034c2d10ea832b1a411ab4d576d5f5152a24cd4513a55871d8f59b50f85c9301bbd7ea27c1aeb84d97b22c076b2768f7
diff --git a/net-misc/teamviewer/teamviewer-13.0.6634.ebuild b/net-misc/teamviewer/teamviewer-13.0.6634.ebuild
new file mode 100644
index 000000000000..6c3cc7311e7e
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-13.0.6634.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN}${PV/\.*}
+inherit eutils gnome2-utils systemd
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_amd64.tar.xz )
+ x86? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="${PV/\.*}"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/dbus
+"
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/${MY_PN}/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+ default
+
+ # Switch operation mode from 'portable' to 'installed'
+ sed -e "s/TAR_NI/TAR_IN/g" -i tv_bin/script/tvw_config || die
+
+ sed -e "/^ExecStart/s/${PN}/${MY_PN}/" \
+ -i tv_bin/script/teamviewerd.service || die
+}
+
+src_install() {
+ local dst="/opt/${MY_PN}" # install destination
+
+ # Quirk:
+ # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+ # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+ # when changing the ABI of one of its dependencies. According to the
+ # TeamViewer devs, this binary is an unused remnant of previous Wine-
+ # based builds and will be removed in future releases anyway
+ rm tv_bin/script/libdepend
+
+ insinto ${dst}
+ doins -r tv_bin
+
+ # Set permissions for executables and libraries
+ for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+ fperms 755 ${dst}/${exe}
+ done
+
+ # No slotting here, binary expects this service path
+ newinitd "${FILESDIR}"/teamviewerd13.init teamviewerd
+ systemd_dounit tv_bin/script/teamviewerd.service
+
+ insinto /usr/share/dbus-1/services
+ doins tv_bin/script/com.teamviewer.TeamViewer.service
+ doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+ insinto /usr/share/polkit-1/actions
+ doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+ for size in 16 24 32 48 256; do
+ newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png TeamViewer.png
+ done
+
+ # Install documents (NOTE: using 'dodoc -r doc' instead of loop will
+ # have the undesired result of installing subdirectory 'doc' in /usr/
+ # share/doc/teamviewer-<version>)
+ for doc in $(find doc -type f); do
+ dodoc ${doc}
+ done
+
+ keepdir /etc/${MY_PN}
+ dosym ../../etc/${MY_PN} ${dst}/config
+
+ # Create directory and symlink for log files (NOTE: according to Team-
+ # Viewer devs, all paths are hard-coded in the binaries; therefore
+ # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+ # <major-version>')
+ keepdir /var/log/${MY_PN}
+ dosym ../../var/log/${MY_PN} ${dst}/logfiles
+
+ dodir /opt/bin
+ dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+ dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+ make_desktop_entry teamviewer "TeamViewer ${SLOT}" TeamViewer
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "Please note that parallel installation of multiple versions of"
+ elog "TeamViewer is currently not supported at runtime. Bug #621818"
+ elog ""
+ elog "Before using TeamViewer, you need to start its daemon:"
+ elog "OpenRC:"
+ elog "# /etc/init.d/teamviewerd start"
+ elog "# rc-update add teamviewerd default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start teamviewerd.service"
+ elog "# systemctl enable teamviewerd.service"
+ elog
+ elog "To display additional command line options simply run:"
+ elog "$ teamviewer help"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}