summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-07 03:00:04 +0000
committerSam James <sam@gentoo.org>2021-01-07 03:06:57 +0000
commit0b37a28ecfdc8d201e53edf80d0de0840d613bb4 (patch)
tree504b41aa1ad1124ce007c6805c4c77d87054bb06 /net-misc
parentnet-libs/libbtbb: bump (diff)
downloadgentoo-0b37a28ecfdc8d201e53edf80d0de0840d613bb4.tar.gz
gentoo-0b37a28ecfdc8d201e53edf80d0de0840d613bb4.tar.bz2
gentoo-0b37a28ecfdc8d201e53edf80d0de0840d613bb4.zip
net-misc/socat: bump to 1.7.4.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/socat/Manifest1
-rw-r--r--net-misc/socat/socat-1.7.4.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
index 0fb684a03572..8a2267984689 100644
--- a/net-misc/socat/Manifest
+++ b/net-misc/socat/Manifest
@@ -1,2 +1,3 @@
DIST socat-1.7.3.4.tar.bz2 490552 BLAKE2B 68db1674a3156b28c10340e515f346de83d4e953570f3a3cdee9402db9f276285a8f46db14978b4651df6d0fa90fb496696f151afb3e826172daa444ee35e666 SHA512 f338d28e5fd9d7ebb9e30b0fa700bcd5ff50ff9e668403474963a3310ba2b5f68b5236b928872c18e4b1ee95328374987e7e263ac7655a0d9b3fc9da77281123
+DIST socat-1.7.4.0.tar.bz2 509023 BLAKE2B 97ad5f5a52375aea4d2afbb4ac6143a86bfa057aed602d552b015f6c9fc6a3a0cc65b1717573b3c60bed482da908197366bd1d282ee1db6fd86a229484d2bb9f SHA512 c4d166c2259271a70f81d6c4972549549c3fc60a9e47cc03eff1dd4d71c298ac39c177ae3c053dc0c97c2770fe8d157fd0bc6f2c14aef91625f868894d5d7c61
DIST socat-2.0.0-b9.tar.bz2 516673 BLAKE2B 808c8821b89ae2463074f87915dfae10f82b66ac6cd0b6ff56ab18f57c704e5a2a3ce76650152dccce41e4bd00e3a937948d4ade0a915b1f0e917c7543c6fc31 SHA512 f728bd634feeeacd2f0e4020c1c6aafdadaef3ba9da818d9ae1195e9f48fb693b2bea8dbbb208af8daddd8d6405217113d5ce31d05c2e9b27f5d2fba6b1cc834
diff --git a/net-misc/socat/socat-1.7.4.0.ebuild b/net-misc/socat/socat-1.7.4.0.ebuild
new file mode 100644
index 000000000000..cce924237d77
--- /dev/null
+++ b/net-misc/socat/socat-1.7.4.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P=${P/_beta/-b}
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="bindist libressl ssl readline ipv6 tcpd"
+
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ readline? ( sys-libs/readline:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
+RESTRICT="
+ test
+ ssl? ( readline? ( bindist ) )
+"
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
+pkg_setup() {
+ # bug #587740
+ if use readline && use ssl; then
+ elog "You are enabling both readline and openssl USE flags, the licenses"
+ elog "for these packages conflict. You may not be able to legally"
+ elog "redistribute the resulting binary."
+ fi
+}
+
+src_configure() {
+ filter-flags '-Wno-error*' #293324
+ tc-export AR
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc doc/*.html doc/*.css
+}