summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-19 20:15:01 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-19 20:16:37 +0200
commit0b4a260697cfe639d719da2a5738fa0ed56d636b (patch)
tree5d776b4608f08c33190b7cade9b5fe06d5ee9c81 /net-misc
parentnet-misc/streamlink: Set DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-0b4a260697cfe639d719da2a5738fa0ed56d636b.tar.gz
gentoo-0b4a260697cfe639d719da2a5738fa0ed56d636b.tar.bz2
gentoo-0b4a260697cfe639d719da2a5738fa0ed56d636b.zip
net-misc/streamlink: bump to 1.3.0
Closes: https://bugs.gentoo.org/697662 Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-1.3.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 6955b4f9ed92..13beee879687 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,3 +1,4 @@
DIST streamlink-0.14.2.tar.gz 643695 BLAKE2B ea28daac32903738206226bce85a4615338b6039be1e4cce18325e977112c3301d6e6ed90d1210f4f362c898397fd980c136a98d8a0d5ff7ee2b6c5cf077f2c6 SHA512 0d9f1db32915392f9d29bcfb40743058352a924435a8ee77f1218c108e937204e88041c908d2f93546beaa70e18db62c961ea31fbdd85c5e7e4315a18118e276
DIST streamlink-1.0.0.tar.gz 674393 BLAKE2B 091272bae71f1e89cf14872578091a01f9d05ee372d4b9379e672280735c6800a33ae198bf019fbb3e970aa060ef059e5106e1be3a20602874be6206b6303bf6 SHA512 22ba96ac0ec27fe923b99898c45548df88ed3dda3bcbcb10b55fea145e20731eb8aa3a90212a5863b4ef5a7387d4bcf3d09d447ea2789762a8cf5eaa87f263d7
DIST streamlink-1.1.1.tar.gz 681973 BLAKE2B a027074e7346ee1758f86456d0d3180bdb3cdbe9be7da232971fe6ece0d0723afa963bff67cef410757d85f7dc356f2a409ad3e84075c03328bbfa995fce796d SHA512 e493e7775eff84b7c70e60606296c71058b0c4ea25920ab6b2efa09cf45765c4b23287258729b60622e57594e7458a320e47301c1821b7211d49f366c73998cd
+DIST streamlink-1.3.0.tar.gz 694190 BLAKE2B cd262290cd81f1954567e217eaf9568c00180ee7f6955c8227b7067488d685385fe8b4b3bcd6004e7e8f7f66236696a48e744cb24c4d00f2111f00633ffeb1bf SHA512 5a114e0b1e617b2a41f8fe00f9bd6846843dd7643b4283d2fe30ea869cc9d6f495458b0ddb97955a87b7ad64e5628343262af5068b8a7a19d0d84a32020b3365
diff --git a/net-misc/streamlink/streamlink-1.3.0.ebuild b/net-misc/streamlink/streamlink-1.3.0.ebuild
new file mode 100644
index 000000000000..04417d2b4e75
--- /dev/null
+++ b/net-misc/streamlink/streamlink-1.3.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 $GIT_ECLASS
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
+DEPEND="
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.23[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ media-video/rtmpdump
+ virtual/ffmpeg
+"
+BDEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )"
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use doc; then
+ local HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ fi
+ distutils-r1_python_install_all
+}