summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2022-07-18 11:24:13 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-19 23:00:28 +0200
commit10d9f5bd4763e9f68a703828fd5383ea2e5d0b0f (patch)
treebc1bf0d2df9d8a00a22a1ebad3173b4b0a0dd5b7 /net-misc
parentapp-admin/calamares: add 3.2.60 (diff)
downloadgentoo-10d9f5bd4763e9f68a703828fd5383ea2e5d0b0f.tar.gz
gentoo-10d9f5bd4763e9f68a703828fd5383ea2e5d0b0f.tar.bz2
gentoo-10d9f5bd4763e9f68a703828fd5383ea2e5d0b0f.zip
net-misc/icaclient: package all utils
We used to keep a list of files to actually package and we did change permission bits on them. Doing that is just error prone and means more maintenance work. Plus the list is different across x86 and x86_64. So now we ship it all and only apply one fix for one binary which has incorrect permission bits in that upstream package. In addition we might see more warnings on "Unresolved soname". We will have to see how to deal with those. But taking the upstream binary bundle apart and only deploying bits is just work which means more work and potential for mistakes. Closes: https://bugs.gentoo.org/856676 Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/26463 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/icaclient/icaclient-22.7.0.20-r1.ebuild (renamed from net-misc/icaclient/icaclient-22.7.0.20.ebuild)33
1 files changed, 3 insertions, 30 deletions
diff --git a/net-misc/icaclient/icaclient-22.7.0.20.ebuild b/net-misc/icaclient/icaclient-22.7.0.20-r1.ebuild
index f7112289fdfe..fe8e4432788b 100644
--- a/net-misc/icaclient/icaclient-22.7.0.20.ebuild
+++ b/net-misc/icaclient/icaclient-22.7.0.20-r1.ebuild
@@ -180,39 +180,12 @@ src_install() {
insinto "${ICAROOT}"/keyboard
doins keyboard/*
+ cp -a util "${ED}/${ICAROOT}" || die
+ test -f util/HdxRtcEngine && fperms 0755 "${ICAROOT}"/util/HdxRtcEngine
+
rm -r "${S}"/keystore/cacerts || die
dosym ../../../../etc/ssl/certs "${ICAROOT}"/keystore/cacerts
- local util_files=(
- HdxRtcEngine
- configmgr
- conncenter
- ctx_app_bind
- ctx_rehash
- ctxlogd
- ctxwebhelper
- echo_cmd
- gst_play1.0
- gst_read1.0
- hdxcheck.sh
- icalicense.sh
- libgstflatstm1.0.so
- lurdump
- new_store
- nslaunch
- setlog
- storebrowse
- sunraymac.sh
- webcontainer
- what
- xcapture
- )
-
- exeinto "${ICAROOT}"/util
- for bin in ${util_files[@]} ; do
- doexe util/${bin}
- done
-
local other_files=(
icasessionmgr
NativeMessagingHost