summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-20 02:14:22 +0100
committerSam James <sam@gentoo.org>2021-04-20 02:20:44 +0100
commit18f832eeda40819e634dacf5f74acddd1e88b6af (patch)
treead30c8709b3903eba58e11ff1af7d750a5e5975b /net-misc
parentnet-misc/tipcutils: port to EAPI 7 (diff)
downloadgentoo-18f832eeda40819e634dacf5f74acddd1e88b6af.tar.gz
gentoo-18f832eeda40819e634dacf5f74acddd1e88b6af.tar.bz2
gentoo-18f832eeda40819e634dacf5f74acddd1e88b6af.zip
net-misc/udpxy: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild b/net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild
index f7f7a11e3a1f..73364f910479 100644
--- a/net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild
+++ b/net-misc/udpxy/udpxy-1.0.23.7-r2.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit systemd toolchain-funcs versionator
+inherit systemd toolchain-funcs
-MY_PV=$(replace_version_separator 3 -)
+MY_PV=$(ver_rs 3 -)
DESCRIPTION="Small daemon to relay multicast UDP traffic to client's TCP (HTTP) connection"
HOMEPAGE="https://sourceforge.net/projects/udpxy/"
SRC_URI="http://www.udpxy.com/download/1_23/${PN}.${MY_PV}-prod.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
src_prepare() {
- eapply_user
+ default
+
tc-export CC
}
@@ -28,7 +28,7 @@ src_install() {
doman doc/en/*.1
dodoc CHANGES README
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
- systemd_dounit "${FILESDIR}/${PN}.service"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
}