summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 13:43:55 +0100
committerSam James <sam@gentoo.org>2023-05-01 13:48:54 +0100
commit244deffeb6fead45ef44b38f982a3a8e5a8f9093 (patch)
tree0b56bd5d1de511b96b2f5c897b404ea75d373e6c /net-misc
parentnet-misc/httpie: drop 2.4.0, 2.5.0, 2.6.0 (diff)
downloadgentoo-244deffeb6fead45ef44b38f982a3a8e5a8f9093.tar.gz
gentoo-244deffeb6fead45ef44b38f982a3a8e5a8f9093.tar.bz2
gentoo-244deffeb6fead45ef44b38f982a3a8e5a8f9093.zip
net-misc/omniORB: drop 4.2.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/omniORB/Manifest1
-rw-r--r--net-misc/omniORB/omniORB-4.2.4.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/net-misc/omniORB/Manifest b/net-misc/omniORB/Manifest
index 55791e76cfe8..d87e33743a47 100644
--- a/net-misc/omniORB/Manifest
+++ b/net-misc/omniORB/Manifest
@@ -1,2 +1 @@
-DIST omniORB-4.2.4.tar.bz2 2713397 BLAKE2B 5759b2563dca421b9a994bb13c30ce6dd98324a2357c4908130a42ce5baec357b881c22b4dff27809607ebde27e7cd65305a91aa5cbdb6d68a19df1f36524e72 SHA512 0b142b127175f16f844823e5adf5593b290528646e13a4c30f6cbd92d159d3998a81b952717039c3f0e386f79404ddd18a3de35fc45fa88383d1d9e51064d988
DIST omniORB-4.3.0.tar.bz2 2762061 BLAKE2B f9103080011a7e683b7e63f6553e8a60947820a331d7c4e3559c961a7f36b17e235c5808e7b282d0227343e6e794106b9f2b93bf138b1a919716d1338e1c9cc2 SHA512 b081c1acbea3c7bee619a288fec209a0705b7d436f8e5fd4743675046356ef271a8c75882334fcbde4ff77d15f54d2da55f6cfcd117b01e42919d04fd29bfe2f
diff --git a/net-misc/omniORB/omniORB-4.2.4.ebuild b/net-misc/omniORB/omniORB-4.2.4.ebuild
deleted file mode 100644
index 1195e57df419..000000000000
--- a/net-misc/omniORB/omniORB-4.2.4.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-
-inherit python-single-r1
-
-MY_P="${P/_p/-}"
-DESCRIPTION="A robust, high-performance CORBA 2 ORB"
-HOMEPAGE="http://omniorb.sourceforge.net/"
-SRC_URI="mirror://sourceforge/omniorb/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
-IUSE="doc ipv6 ssl"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- ssl? ( dev-libs/openssl:0= )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
-
- # The OPTC(XX)FLAGS variables aren't present in these files, but we
- # will set them when we call emake.
- sed \
- -e 's/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = $(OPTCXXFLAGS)/' \
- -e 's/^CDEBUGFLAGS.*/CDEBUGFLAGS = $(OPTCFLAGS)/' \
- -i mk/beforeauto.mk.in mk/platforms/i586_linux_2.0*.mk || \
- die "failed to switch CFLAGS variables in the makefile includes"
-
- # The out-of-source build is suggested by upstream.
- mkdir build || die "failed to create build directory"
-}
-
-src_configure() {
- cd build || die "failed to change into the build directory"
-
- ECONF_SOURCE=".." econf \
- --disable-static \
- --with-omniORB-config=/etc/omniorb/omniORB.cfg \
- --with-omniNames-logdir=/var/log/omniORB \
- --libdir="/usr/$(get_libdir)" \
- $(use_enable ipv6) \
- $(use_with ssl openssl "/usr")
-}
-
-src_compile() {
- cd build || die "failed to change into the build directory"
- emake OPTCFLAGS="${CFLAGS}" OPTCXXFLAGS="${CXXFLAGS}"
-}
-
-src_install() {
- cd build || die "failed to change into the build directory"
- default
-
- rm "${ED}/usr/bin/omniidlrun.py" || \
- die "failed to remove redundant omniidlrun.py"
-
- cd "${S}" || die "failed to change into the ${S} directory"
-
- dodoc CREDITS doc/*.html ReleaseNotes.txt update.log
- dodoc -r doc/omniORB
-
- if use doc; then
- dodoc doc/*.pdf
- fi
-
- cat <<- EOF > "${T}/90omniORB"
- PATH="/usr/share/omniORB/bin/scripts"
- OMNIORB_CONFIG="/etc/omniorb/omniORB.cfg"
- EOF
- doenvd "${T}/90omniORB"
- doinitd "${FILESDIR}"/omniNames
-
- cp "sample.cfg" "${T}/omniORB.cfg" || die
- cat <<- EOF >> "${T}/omniORB.cfg"
- # resolve the omniNames running on localhost
- InitRef = NameService=corbaname::localhost
- EOF
- insinto /etc/omniorb
- doins "${T}"/omniORB.cfg
-
- keepdir /var/log/omniORB
-
- python_optimize
- python_fix_shebang "${ED}"/usr/bin/omniidl
-}